Jump to content

Photo

Atari 7800 - problem with controllers


3 replies to this topic

#1 lewiS OFFLINE  

lewiS

    Space Invader

  • 11 posts
  • Location:Slough, UK

Posted Mon Feb 11, 2019 7:31 AM

Hi all,

I am very new to Atari 7800 world and I need some advice from more experienced users.

 

Let me explain the whole story. I have purchased my first Atari 7800 about a month ago. As I am based in UK, it is PAL console (let's name it unit A). It came with two europads and two games (Jinks and Barnyard Blaster). Over the period of the month I have bought another 8 games and I have discovered that second fire buttons on my controllers do not work. I have also bought 3rd europad and managed to borrow Proline controller off the person who is sure that is working fine.

 

None of these had working secondary fire button on my console. Moreover, the Proline had no working buttons at all. I have disassembled all 3 europads and cleaned them inside. While doing that and I have connected them to the console and tested both buttons, but no change. Only first fire button worked. Strangely enough when I plug 2600 game both buttons work as a charm.

 

Frustrated with that, I came to the conclusion that there is something wrong with the console itself. I have then purchased second PAL Atari 7800 (lets name it unit B). The situation improved a little, as most of the controllers started to work fine. I mostly tested them with Choplifter! and Crack'ed as there are clear indication when the second fire is used. However it then started to go downhill. When playing Choplifter! both buttons completely randomly stopped to work altogether. Then after 30 seconds they started to work again. I have tried to swap europads and Proline while having the console on and in some cases it helped out (one or two buttons started to work), in some cases it did not. I have had situations that first button or both buttons stopped to work, I swapped europads, didn't help, switch off the console, switched on and both buttons were OK. Or disassembled europad while still connected and used rubber from underneath the plastic button to make a contact - it worked. Completely random. This all happened on unit B.

 

So I have done yet another test: connected unit A, got Choplifter! in, connected same Europad which worked a moment ago with both buttons on unit B, started a game and second fire started to work. It never worked on unit A. My happiness lasted exactly for 1 second, because when I pressed secondary fire again it didn't work. And since then never worked again...

 

And to be on the safe side: I tried with two different copies of Choplifter!

 

On top of that first fire button sometimes not work in unit A without any reason. I speak about such situations as starting Asteroids (built in ROM of course) and not able to fire a shot. I switch off the console and switch on again, everything works. Or wait for a minute (even with Pause), then everything goes back to "normal". I mean one button working.

 

And such hiccups also happen on unit B, but less often.

 

I am completely puzzled. I have 2 consoles, 4 controllers and buttons works intermittently on several combinations of all. I read here on the forums that it can be an issue with TIA, but before I spend any more money doing anything more, I would like to hear some advice on direction I could go.

 

Any advice will be highly appreciated.



#2 slx OFFLINE  

slx

    Stargunner

  • 1,679 posts
  • Location:Vienna, Austria

Posted Mon Feb 11, 2019 3:19 PM

Have you tried measuring the resistance between pins of the controller with a multimeter? Check whether the controllers show consistent values. The second button should register on its own pin as well as button 1 pin (with a different resistance value) as the 7800 sticks are wired for both buttons to register as button 1 on VCS and 8-bit.

If the controllers work consistently, theres something wrong with your console (but I dont know how to troubleshoot that).

#3 Stephen Moss OFFLINE  

Stephen Moss

    Stargunner

  • 1,130 posts
  • Location:Cambridge, United Kingdom

Posted Tue Feb 12, 2019 2:13 AM

I could be the controller lead, either at the plug end or the controller end. After years of flexing particularly when the cable are coiled around the controller where then ends are pulled tight the cable can go open circuit.

This is not easy to test if you do not have a second person but can basically be done as follows...

Plug in the controller with one person holding it still and keeping the fire buttons depressed, the second person hold the cable still at its mid point and basically wiggles it around playing particular attention to flexing it at the point it enters the controller. If you get no change that half of the cable is ok, then try the other half of the cable paying particular attention at the point it enters the connector,  again if there is no change then the cable and controller port connector on the console are probably fine.

 

Move the cable slowly if there is a break in the cable there is like to be only one specific spot where the connection will be made and the controller will function correctly, as most people hold and use the controller the will tilt and twist it slightly which in turn moves the cable. Consequently when a damaged cable is in the correct position the connection is reestablished and the controller works, move it slightly and the controller stops working.

 

The fact it only appears to affect the Fire could indicate the problem lies elsewhere but this is simple test to try that may at least indicate if the issue lies with the controller or the console.          



#4 lewiS OFFLINE  

lewiS

    Space Invader

  • Topic Starter
  • 11 posts
  • Location:Slough, UK

Posted Tue Feb 12, 2019 3:24 AM

That is helpful Stephen, I will try employing someone :)

 

slx: didn't test the resistance yet.

 

Thanks so far!






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users