Jump to content

Photo

Anyone emulate Sega's Star Wars Trilogy at full speed?


2 replies to this topic

#1 wongojack OFFLINE  

wongojack

    River Patroller

  • 3,361 posts
  • Location:Texas

Posted Sun Apr 21, 2019 1:25 PM

It doesn't work in MAME (I think), so I downloaded the Sega Model 3 emulator known as 'supermodel.'  I got the ROM from . . . somewhere and the game works great, but it only runs at around 20 FPS.  I can't tell if it is just my computer or some yet untried option in the emulator.

 

Anyone ever get this game to run at full speed that can offer some advice?

 

 

In case you want to try this

Get supermodel here:  http://www.supermode....php?f=3&t=1206

 

To get the ROM, try searching for Star Wars Trilogy Arcade (Revision A) on a site like edgeemu.net

 

 



#2 A8Watcher_808 OFFLINE  

A8Watcher_808

    Space Invader

  • 16 posts

Posted Sun Apr 21, 2019 6:14 PM

I just tried it on my living room setup for the big screen and it runs full speed. It's on my older gaming computer which is running a Phenom II X4 at around 3200mhz and geforce 750ti, I believe. I used the default settings and got a full 60fps.

 

Going through the readme file I didn't see much settings to improve performance. If you're trying it on a single-core system you could try running it with the -no-threads option. It looks like it uses opengl so maybe you need updated video drivers? Or maybe you could mess with the PowerPC frequency setting. According to the readme it sets the PPC frequency in MHz with the default at 50. Lowering it may improve performance but may cause timing issues and jerkiness. It says that 25 MHz works in many games. To set that you would use the -ppc-frequency=25 (or any value between 1 and 1000). Hopefully one of those things work.

 

Now the only thing I need to figure out is how to change the mouse settings for the lightsaber battles.



#3 wongojack OFFLINE  

wongojack

    River Patroller

  • Topic Starter
  • 3,361 posts
  • Location:Texas

Posted Sun Apr 21, 2019 7:51 PM

Yeah, I guess my computer is a bit underpowered for it.  It only runs around 20 fps (which is a nice practice mode).

 

I tried a number of those options, but I didn't try lowering the mhz of the power pc.  I'll give that a try and see if it helps.  I think I just need a newer PC for this.

 

EDIT - lowering the mhz to 25 definitely helped.  I'm not at 60fps or anything, but it shot way up.  I do get some glitching, but at least it feels like a game now.  I also know the problem is that my laptop is underpowered.






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users