Jump to content

Photo

Is Vader (2600) dead?

2600 Vader Atari Composite Mod dead Glitches

3 replies to this topic

#1 relo999 OFFLINE  

relo999

    Star Raider

  • 75 posts
  • Location:The Nether-lands

Posted Sun Apr 21, 2019 5:43 PM

Recently got an 2600 (Vader) and gave it an composite mod. That mod seemed to work fine for a few times but after a while gave increasingly more glitches with each power cycle. First blocks in the screen, then the games where effected by the power switch (in combat suddenly the tanks moved), then the image stopped working and just getting a buzzing sound and now I only get a black screen without sound.

 

What could cause this issue?



#2 Lohe ONLINE  

Lohe

    Space Invader

  • 17 posts
  • Location:Graz, Austria

Posted Tue Apr 30, 2019 3:20 AM

Did you check the temperature on the TIA chip? The one right at the cartridge connector. Does it get hot? I did an av mod also, after that the TIA went really hot, so hot you couldnt put your finger for longer than 2 seconds on it, and till then the picture stays dark. Last info was NTSC signal catched by my televisions info panel. On a pal console. Imagine.

My problems with an av modded vader began the same way as your ones. First it was good, then got worse and now it is dead also. I believe I need a new TiA, but a new console I can get for less than 15.

Good to have a working jr. here I have to say. Lousy RF signal. Nothing recapped, nothing changed! But works!

Edited by Lohe, Tue Apr 30, 2019 3:22 AM.


#3 relo999 OFFLINE  

relo999

    Star Raider

  • Topic Starter
  • 75 posts
  • Location:The Nether-lands

Posted Fri May 3, 2019 4:01 PM

Playing with the chroma dial somehow fixed it...

Really weird, but I'll take it...



#4 Lohe ONLINE  

Lohe

    Space Invader

  • 17 posts
  • Location:Graz, Austria

Posted Sat May 4, 2019 6:33 AM

Good to hear. My TIA is also fine again. Just one pin was not correctly placed in the holder. AV mod looks fine. Crisp and clear.





Also tagged with one or more of these keywords: 2600, Vader, Atari, Composite, Mod, dead, Glitches

0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users