Jump to content
Sign in to follow this  
  • entries
    5
  • comments
    3
  • views
    11,153

Oh Hell...

Sign in to follow this  
Devbinks

575 views

Okay, so I used to own, both, an NES and an SNES. Over the past few years, I've had a desire to start collecting as many older game systems as I can. So, today I went to a local Play N Trade and reacquired the NES and SNES.

 

Well, the NES works okay so far. Just needed a bit of cleaning.

 

The SNES, however, only gave me a black screen with several horizontal white (grey-ish) lines. I figure, okay, I'll take it back and exchange it.

 

I got back to Play N Trade and explain the problem. The employee tries it out and gets a blue screen saying "No Signal". This baffle shim as he claims he had tested it just three days prior and it worked perfectly. In any case, he exchanges it for another SNES. This system, he tests right in front of me to make SURE it's not defective. It works fine so I take it home.

 

Well, I hook it up to THREE different TVs, trying both RF out and AV out. Guess what... I get the black screen with white lines! Exact same problem as the one I just exchanged!

 

I'll update this tomorrow most likely. I'm going to take the SNES back and wait for them to get yet another SNES in lol

Sign in to follow this  


0 Comments


Recommended Comments

There are no comments to display.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...