Jump to content

shaggyneo

New Members
  • Content Count

    19
  • Joined

  • Last visited

Community Reputation

25 Excellent

About shaggyneo

  • Rank
    Space Invader
  1. I really appreciate all of the help. Upon closer inspection I did find some corrosion on a couple of the pins on u17 and u30. After using some ipa and a soft toothbrush to clean it up a bit I am now getting just a black screen. It seems like it is being held in reset. My friend got this unit traded into his shop and he asked me to look at it for him. It is getting beyond what I am want to dive into as a favor so I am just going to give it back. It was known as red screen when he took it in so it was a gamble to start with. Again I really appreciate all of the help.
  2. I have a Jaguar I am trying to figure out what is causing the red screen of death. The cart slot seems to be fine. I inserted a blank cart PCB and tested the connection to the bottom of the motherboard and everything has continuity. All of the caps seem fine and I tried a new bios chip. Every game I try goes to a red screen except my skunkboard. The skunk works perfectly with any game I flash to it. I'm out of ideas. Does anyone have any experience with anything else causing the red screen? Thanks in advance for your time.
  3. I love CRT's for retro consoles. I have 3 in my main game room setup. I have more in storage just because I can't resist them.
  4. I ended up taking the usb ports off of mine and putting it a standard cart shell with a custom label. Put a micro usb port on the top of the cart to connect to my PC.
  5. I appreciate the advice. I'm going to see if I can find the chips and replace them. Thanks again.
  6. I have a strange video issue with one of my Jaguar consoles. When it is connected through s-video or composite video it looks like a rave is happening on the screen. When I connect it through scart it looks fine. My other console works fine connected with the same cables to the same TV. I added a video showing what I'm talking about as well as a video of the other console connected with the same cables. Any ideas what could be causing this issue? I checked the board and nothing jumped out at me. Any help would be appreciated, thanks. 20190707_152556000_iOS.MOV 20190707_152638000_iOS.MOV
  7. My Atari has them in their ebay store as well. https://www.ebay.com/itm/Atari-Jaguar-Replacement-Cartridge-Connector-ONE-only-NEW-Original/143164414633?hash=item2155439aa9:g:BPAAAOSwfl1cgwGX
  8. My Toshiba Nuon recently quit reading disks. Does anyone know where I can source a new laser or know of other Toshiba players that would use the same drive that I can scavenge from? Any help would be greatly appreciated. Thanks.
  9. I have most of the ST ports and the two I play the most are Badlands and Star Wars. The Off-Road/Mad Max style of Badlands is way too much fun and the mouse support on Star Wars is amazing. I also love some of the extras that have been put into the ports like the ability to select the different audio modes in Joust and the addition of arcade sounds in Star Wars. A lot of love went into these ports and I really appreciate having them in my collection. I did have to pass on a few for financial reasons but will definitely acquire them at some point.
  10. Invoice paid. Thanks so much for making these games available.
  11. I did something similar for my jag using an old pelican real arcade stick. It has the button layout of the pro controller and a rotary for Tempest. Still need to add new buttons but it works great.
  12. The sprite jump glitch happens on my machine. Pretty sure mine is a K model.
  13. I guess I'm one of the lucky few as well. I got my "less than reliable" cart this afternoon. I'm not even going to open it. Just going to wait patiently for the updated version to arrive.
  14. I've never really paid attention to it before but mine does the same thing when running through my OSSC.
×
×
  • Create New...