Jump to content

shaggyneo

New Members
  • Content Count

    14
  • Joined

  • Last visited

Community Reputation

11 Good

About shaggyneo

  • Rank
    Space Invader
  1. I appreciate the advice. I'm going to see if I can find the chips and replace them. Thanks again.
  2. I have a strange video issue with one of my Jaguar consoles. When it is connected through s-video or composite video it looks like a rave is happening on the screen. When I connect it through scart it looks fine. My other console works fine connected with the same cables to the same TV. I added a video showing what I'm talking about as well as a video of the other console connected with the same cables. Any ideas what could be causing this issue? I checked the board and nothing jumped out at me. Any help would be appreciated, thanks. 20190707_152556000_iOS.MOV 20190707_152638000_iOS.MOV
  3. My Atari has them in their ebay store as well. https://www.ebay.com/itm/Atari-Jaguar-Replacement-Cartridge-Connector-ONE-only-NEW-Original/143164414633?hash=item2155439aa9:g:BPAAAOSwfl1cgwGX
  4. My Toshiba Nuon recently quit reading disks. Does anyone know where I can source a new laser or know of other Toshiba players that would use the same drive that I can scavenge from? Any help would be greatly appreciated. Thanks.
  5. I have most of the ST ports and the two I play the most are Badlands and Star Wars. The Off-Road/Mad Max style of Badlands is way too much fun and the mouse support on Star Wars is amazing. I also love some of the extras that have been put into the ports like the ability to select the different audio modes in Joust and the addition of arcade sounds in Star Wars. A lot of love went into these ports and I really appreciate having them in my collection. I did have to pass on a few for financial reasons but will definitely acquire them at some point.
  6. Invoice paid. Thanks so much for making these games available.
  7. I did something similar for my jag using an old pelican real arcade stick. It has the button layout of the pro controller and a rotary for Tempest. Still need to add new buttons but it works great.
  8. The sprite jump glitch happens on my machine. Pretty sure mine is a K model.
  9. I guess I'm one of the lucky few as well. I got my "less than reliable" cart this afternoon. I'm not even going to open it. Just going to wait patiently for the updated version to arrive.
  10. I've never really paid attention to it before but mine does the same thing when running through my OSSC.
  11. I too am curious if there is an update to when they will start shipping out.
  12. Payment sent. Thanks so much. Can't wait to get it.
  13. Just ordered mine. Can't wait to play it!!!
×
×
  • Create New...