Jump to content
mega-hz

THE!CART... New 128MB FLASH Cartridge

Recommended Posts

4 hours ago, gozar said:

Am I missing something? When I insert .XEX files, they show up as Unknown. And there isn't a group option to change Content Type, I have to change each .xex file individually to executable.

> Auto-Detection was simply not yet implemeted, I first did the Atari part to get feedback if it works as expected. It's in the making.

 

On 10/29/2019 at 12:20 AM, FULS said:

JAC!

Is there any way to get this "Bounty Bob Strikes Back" on this ATR to work with TheCart!

This is the best ever file version of BBSB. It survives the Reset Button pressed. All others after reset is pressed locks-up on screen #2 hydraulic lift.

Plus you can use the easter egg cheat codes.

BOUNTY.com 40.33 kB · 14 downloads

GAMES049.ATR 179.64 kB · 9 downloads

Thanks,

Doug

Will check that!

Share this post


Link to post
Share on other sites

The!Cart Studio Update: 2019-11-04

 

  • Content type "Executable File" is now set automatically when executables files (COM,EXE,XEX) with a valid file structure are added.
  • New content type "SAP Music File" has been added and is set automatically when Slight Atari Player files (SAP) with a valid file structure are added. These files will be supported directly by the menu in future.
  • Like 5
  • Thanks 1

Share this post


Link to post
Share on other sites

Any Chance, that you update the Mac-app to 64Bit? This is on OS X.15.1 Catalina:

 

2000352910_Bildschirmfoto2019-11-04um01_55_54.thumb.jpg.c0c8bf4c2f8a9b8fd309321ff4ac5af7.jpg

 

1664593683_Bildschirmfoto2019-11-04um01_55_40.thumb.jpg.17987e7f69deb2b50681357279897f39.jpg

Share this post


Link to post
Share on other sites

Hi Peter,

I cannot start any ATR menu entries since the update to The!Cart Studio 2019-11-04 00:17:37. If I choose an ATR entry then the Atari just boots from drive 1.

Anny idea?

CU

Holger

Share this post


Link to post
Share on other sites
3 hours ago, janzh said:

Hi Peter,

I cannot start any ATR menu entries since the update to The!Cart Studio 2019-11-04 00:17:37. If I choose an ATR entry then the Atari just boots from drive 1.

Anny idea?

CU

Holger

You should go back to "28.10.19" for the moment. Everything after this is pretty buggy. I think Peter will fix it soon and I will check it out....

 

 

Bern

 

  • Like 1

Share this post


Link to post
Share on other sites

Looks like the upload of the last build 2019-11-05 07:58:41 to the web site was not complete. I've re-uploaded it now.

For those who have a backup, please test again.

For those who are happy with their current content, please wait until the correct operation is confirmed again!

  • Like 1

Share this post


Link to post
Share on other sites

Update: Tests have confirmed that now everything is back to normal and the latest version with automatic detection of the "XEX" content types works just fine.

Thanks to Biobern and Holger for testing!

  • Like 3
  • Thanks 1

Share this post


Link to post
Share on other sites

@JAC! I had a flashing error.  I followed the prompts until the program ask Quit y/n and I pressed Y and now I can't get the!cart to boot the atr or get into Flashing menu..

Boot Error or starts the self test menu..

 

Share this post


Link to post
Share on other sites
10 hours ago, Roydea6 said:

@JAC! I had a flashing error.  I followed the prompts until the program ask Quit y/n and I pressed Y and now I can't get the!cart to boot the atr or get into Flashing menu..

Boot Error or starts the self test menu..

 

Hello Roy,

please check the section"Important: If The!Cart does not start anymore after flashing"

https://www.wudsn.com/productions/atari800/thecartstudio/help/TheCartStudio.html

 

and report it if helps.

  • Like 1

Share this post


Link to post
Share on other sites
On 11/4/2019 at 1:57 AM, skr said:

Any Chance, that you update the Mac-app to 64Bit? This is on OS X.15.1 Catalina:

 

2000352910_Bildschirmfoto2019-11-04um01_55_54.thumb.jpg.c0c8bf4c2f8a9b8fd309321ff4ac5af7.jpg

 

1664593683_Bildschirmfoto2019-11-04um01_55_40.thumb.jpg.17987e7f69deb2b50681357279897f39.jpg

Hi Sascha,

the core of the app is Java anyway, the ".app" is just a small wrapper provided by somebody else. I'll have to check, but there will for sure be an update for the wrapper somehow. And I'll have to see if I can update my test-Mac. Bern told me that there are many incompatibilities with 32 bit now.

Share this post


Link to post
Share on other sites
On 11/4/2019 at 12:20 AM, gozar said:

Well, I flashed The!Cart, and now the computer doesn't act like there is anything inserted. Any ideas?

Hi gozar,

 

Please also follow the section "Important: If The!Cart does not start anymore after flashing".

https://www.wudsn.com/productions/atari800/thecartstudio/help/TheCartStudio.html

 

Regards, Peter.

Share this post


Link to post
Share on other sites
51 minutes ago, JAC! said:

and report it if helps.

Yes this helped.  I knew about this flasher MyDos version, but over years I had forgotten.

  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, JAC! said:

Hi Sascha,

the core of the app is Java anyway, the ".app" is just a small wrapper provided by somebody else. I'll have to check, but there will for sure be an update for the wrapper somehow. And I'll have to see if I can update my test-Mac. Bern told me that there are many incompatibilities with 32 bit now.

"Incompatibility" is sweet. Actually, 32 Bit apps are not supported at all by OS X Catalina anymore. This is, why I currently also can´t run Altirra, as "wine" is not on 64 Bit right now. But the community is working on it, and maybe there are updates soon. 

Share this post


Link to post
Share on other sites

Well, I've flashed my cart twice. After it is done, I try to use The!Cart, but the computer acts like the cart doesn't exist and I have to reflash the base image.

 

Anyone have an idea what I'm doing wrong? I'm going to put together a small workbook and try it. 

Share this post


Link to post
Share on other sites
3 hours ago, gozar said:

Well, I've flashed my cart twice. After it is done, I try to use The!Cart, but the computer acts like the cart doesn't exist and I have to reflash the base image.

 

Anyone have an idea what I'm doing wrong? I'm going to put together a small workbook and try it. 

Which type of computer? 400/800/800XL/XE?
Any special OS installed?
Does it boot to BASIC?

What happens if you hold down the RESET button on The!Cart itself during Power-up? Do you see a rainbow effect?

Share this post


Link to post
Share on other sites
23 hours ago, JAC! said:

Which type of computer? 400/800/800XL/XE?
Any special OS installed?
Does it boot to BASIC?

What happens if you hold down the RESET button on The!Cart itself during Power-up? Do you see a rainbow effect?

1200XL with a U1M, but stock OS and SDX & PBI stuff turned off. It will boot Basic. I'll try the reset button and let you know. Next will be to grab a stock machine and see what happens. 🙂

 

Thanks!

Share this post


Link to post
Share on other sites

The!Cart Studio Update 2019-11-26 released

  • Columns "Title", "Genre", "File Path" and "File Name" are now sorted case-insensitively.
  • Fixed file exception when adding "Goonies.atr", "ElektraGlide.atr", "Rampage.atr" and other ATR files.
  • Like 6
  • Thanks 1

Share this post


Link to post
Share on other sites

The!Cart Studio Update 2019-11-24 released

  • The tabbed display for the genres now only scrolls, if the select genre does not fit on the screen. This is what you'd expect from a tabbed visualization.
  • The XEX loader now sets the BOOT? flag to $01, like a DOS would. This fixes problems with programs that rely on the XEX being loaded from a disk.

 

This version contains the a new data format for storing the genres in on the Atari side. It is the pre-condition to make the favorites feature work in the next round.

 

 

1.png2.png3.png4.png5.png

  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites
On 12/24/2019 at 1:09 PM, tajvdz said:

ok, thank you. I have only an Sdrive Max now. I'm also thinking about buying a cartidge based device. What would you advise?

Well, my obviously biased advice would of course be "The!Cart" ... after all you are asking this in the "The!Cart" thread 🙂.

With Sdrive max you have a very good SIO solution that can handle all disk stuff and quick testing.

With The!Cart you have a almost 100% emulation of everthing else (ROM based stuff, but also ATR/XEX).

A new run is planned to be available in Q1/2020.

  • Like 6

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...