Jump to content
Goochman

Venture Official Release

Recommended Posts

gently clean the cart slot and the cartridge, don't bend or stretch the metal in the cart slot though...

chances are it's another bad rom, bad burn, or solder joint etc... they really need to work on quality control... of course sometimes it's the code itself...

real machines make real men... emulators are fine for fiddling but not fit for the finish.. ;)

Edited by _The Doctor__

Share this post


Link to post
Share on other sites

Also, the game totally crashes on me from time to time. Today it did so on Map 2 Level 2 when I bumped into a wall while trying to escape from a hall monster. Yesterday it did in one of the rooms on Map 4 Level 1. I have to cold start my XL when this happens in order to get the cartridge to run again.

You can try cleaning the cartridge port. Do you know if this is the 16K cartridge or the 32K cartridge. 32K will the tan/grey color, 16K will be brown and grey and take a few seconds for the title to come up. If its 16K, there may be an issue if you stayed inside one of the map screens too long, hear some distortion. What happened during beta testing, KJMANN and I were just quickly going into dungeon rooms from the map screen and going to next dungeon room. We wanted to replace the more expensive 32K as quick as we can. I know I wish I had my modern group of beta testers back in 2011 through 2014 during development.

Share this post


Link to post
Share on other sites

I get this vision of a group of skeletons strapped to chairs with a joy pad in their fingers as the only trusted beta testers, dead folks can't pirate code....

  • Like 3

Share this post


Link to post
Share on other sites

We know dead men tell no tails... but if the beta testers are indeed feared as a bunch of pirates... was that treasure booby trapped and they all fell ill...taking the darker secrets with them?

 

Sorry couldn't resist...

 

_Commander Adama__

Edited by _The Doctor__
  • Like 3

Share this post


Link to post
Share on other sites

You can try cleaning the cartridge port. Do you know if this is the 16K cartridge or the 32K cartridge. 32K will the tan/grey color, 16K will be brown and grey and take a few seconds for the title to come up.

I've cleaned my cartridge port, that's not the issue. I do not have similar problems with any other cart.

 

My copy of "Venture" is the newer 16K release.

Share this post


Link to post
Share on other sites

There is a known issue if you stayed still inside the map room for over a minute. This is one of those conflicts that happens between the RMT player, the song file KJMANN sent me, and the game main VBI routine. I corrected the issue by hacking KJMANNs song file, added a blank song line to RMT and have it go in an endless loop after that short piece of music plays when you enter a room. The only way you can avoid this you cannot stay inside the map room too long, if the hall monsters do not get you first.

Share this post


Link to post
Share on other sites

Say what? really....come on dude you can't just keep doing this to people. Fix it and replace his cartridge. WTF!!!!!!

If it is already fixed, why are we selling old versions, just update the carts before sending them out... I just can't wrap my head around any of this. If you're still some kind of worry about piracy crap then develop some kind of secure burner w/ secure software that you can sell, (as is the V61 way) so people aren't screwed like this...and contrary to what may be said... make no mistake, you pay the crazy amounts for this stuff, the least it could be is major bug free. Please don't say taking too long and crashing/irretrievably locking up our machines is a minor glitch or bug.

 

Every time I start to support you in the littlest way, you say and do some sh*t like this. At this point I am begging you to please change the mindset and methods you're production team employs, it's tarnishing what people expect from Atari and it's developer community. Stop refusing beta testing from people who have done this for a pay check, or indeed programmed for major companies back in the day. I would say you are only hurting yourselves, but that's not the case. At least 5 different people have gotten 'treatment' that have come to light publicly... and more who have emailed (at least they say they have) to get nothing other than it's part of the experience or some such nonsense. If it were just a mistake and happened once or such no one would be upset. It's not the case though....

 

Everyone strives to do the best they can do, home brew or otherwise, they always provide a fix, even if it's soldering iron they get it done by some other replacement method

Edited by _The Doctor__
  • Like 4

Share this post


Link to post
Share on other sites

If this is a known issue with the 16K version of Venture, I would be satisfied with being provided privately with a ROM of the 32K version that I could then use on my Ultimate Cart so that I could play the game bug-free. I agree with _The Doctor_, though, that the bug should be fixed before any more cartridges are sold.

Share this post


Link to post
Share on other sites

The bug may be from bad burns with the compressed 16K version of Venture. The issue was investigated awhile ago, and part of the code had to re-written to get around the issue. When I was going through the source code and porting it to the 5200. I was also investigating ways to reduce the time it takes inflate to decompress larger files at the time. The 7800 version needs to have large sections re-written since that will need to work with different hardware. Video61 has been shipping the corrected version. If anyone has problem with the cartridge, need to contact Video61. We only support people that purchased the actual game on cartridge.

 

I am going to busy with working on the 7800 ports, so I will not be posting on here much. Will only responded to issues the game itself.

Edited by peteym5

Share this post


Link to post
Share on other sites

We only support people that purchased the actual game on cartridge.

 

I am going to busy with working on the 7800 ports, so I will not be posting on here much. Will only responded to issues the game itself.

That would be me. What I am asking is if you could PRIVATELY send me a copy of the 32K uncompressed ROM if the bug is a result of the compression of the 16K cartridge that I have purchased. I am asking you in good faith as the programmer to help by providing me with a bug-free file that I can actually use on my 800XL without crashing. The crashing issue is not an infrequent bug; it seems to happen about 10-15% of the time that I play the game. I really do enjoy playing this A8 port of the game but it can be frustrating not knowing if the cartridge will crash or not before I actually finish playing. I do not feel that this is an unreasonable request for me to make as all that it would require on your end is sending me a ROM copy of the file via a private message. Thanks.

post-1863-0-05133700-1513609500.jpg

Edited by SS
  • Like 1

Share this post


Link to post
Share on other sites

You have more chance of finding rocking horse sh*t than Petey doing that, he's so paranoid about rom files getting out that he WILL stuff a customer over even though its proved that its his process that caused the cock up.

 

The service this man offers is just bizarre......Don't even ask him for digital downloads.....He goes full retard....

  • Like 5

Share this post


Link to post
Share on other sites

I'm not asking for a digital download though. I am asking for a PRIVATE good faith fix between Pete and myself.

Share this post


Link to post
Share on other sites

Its not up to Pete to release a digital download - there are other parties that also have to agree. With the past history its very unlikely a digital download will be provided.

Share this post


Link to post
Share on other sites

I know you are not asking for a digital download SS, sadly Petey's attitude towards his customers just makes me confused and annoyed, maybe he will stun me and do the right thing but his blaming of his very own customers as being pirates just borders on lunacy.

  • Like 2

Share this post


Link to post
Share on other sites

The bug may be from bad burns with the compressed 16K version of Venture. The issue was investigated awhile ago, and part of the code had to re-written to get around the issue. When I was going through the source code and porting it to the 5200. I was also investigating ways to reduce the time it takes inflate to decompress larger files at the time. The 7800 version needs to have large sections re-written since that will need to work with different hardware. Video61 has been shipping the corrected version. If anyone has problem with the cartridge, need to contact Video61. We only support people that purchased the actual game on cartridge.

 

I am going to busy with working on the 7800 ports, so I will not be posting on here much. Will only responded to issues the game itself.

peteym5,

wtf is with this? He bought the Game he can prove it and he even posted pictures of the cartridge.... you guys should apologize and make it right! Clearly your production/distributor and yourself were aware of the problem and you know who the customers are who bought them... why wouldn't the purchasers have been contacted and given options to get this resolved like honorable reputable retailers?

 

You are hurting yourselves and can't see it.... that's the frustrating part for all who watch this continual slow motion slide from the rails....

  • Like 3

Share this post


Link to post
Share on other sites

Anyone who purchased the game should send me a private message. Also they may need email or call Video61 at Atarisales directly. I would need to know when the game was purchased.

Edited by peteym5
  • Like 4

Share this post


Link to post
Share on other sites

Anyone who purchased the game should send me a private message. Also they may need email or call Video61 at Atarisales directly. I would need to know when the game was purchased.

Pete, I will send you a PM this evening once I get home. Thanks.

  • Like 2

Share this post


Link to post
Share on other sites

Pete,

I have already sent you a PM with my order information since I have had the same crashing behavior that SS has seen. I do not know if a picture of the cartridge would be helpful, but here it is.


Bob C

post-40058-0-04053400-1513640146.jpg

Share this post


Link to post
Share on other sites

Anyone with an issue with the game has to contact video61 [email protected] He is the one selling the cartridges and he is the one going to handle the issues in private. All technical support and customer support issues will now be done in private with those who own the game. I did not bring up or respond to any subjects that will escalate this into a furious debate. We are investigating what is going on to if the correct version of the game was recently burned onto the EPROMs at this time.

Edited by peteym5

Share this post


Link to post
Share on other sites

I sure hope that all the people with problems feel free to discuss what happens in public, and that everyone continues to discuss what's good and bad.... If they didn't they'd all be stuck wondering if they're the only one. At least when it's in the sunlight something finally gets done about it.

  • Like 1

Share this post


Link to post
Share on other sites

Merry Christmas everybody. You can post any issues on here, but if anyone needs a replacement needs to contact Video61 or private message me for further assistance. I know everyone is busy this time of year. I did submit an updated version of Venture that will be tested on real hardware. I hope to see an updated cartridge should be put out sometime after the holidays.

  • Like 5

Share this post


Link to post
Share on other sites

Merry Christmas everybody. I can see people should not be complaining about the labels on the cartridges. Look great to me.

 

I am working on porting several games over to the 7800 right now and in that thread I posted many screen shots. Venture for the 7800 seems to be in high demand.

http://atariage.com/forums/topic/272251-my-8-bit-games-porting-to-7800-in-the-works/page-3 I am trying to be more open about new games during the work-in-progress to get feedback before the cartridges are completed. Since the 5200 & 7800 are cartridge based, seems to be a much higher percentage wanting a real physical cartridge and manuals.

 

Anyone with concerns with our games can post on here and I will read them. There is no need for bashing and insults. However, to assist people further, they do need to send me a PM or contact Video61 as we will need their contact information. Very sure people will not post that publicly. As we may need information for verification, track, where to send stuff, or whatever else. After all we cannot send them the cartridge through electronic communications. Also, we will not be posting any ROM images publicly, ourselves. From what I understand, no one has contacted Video61 directly about stated issues on here with Venture.

Edited by peteym5

Share this post


Link to post
Share on other sites

No one has asked you to post rom images publicly, just to aid the people who have problem products....Just basic customer service...

 

Sorry, just seemed you were trying to head back down the piracy road for no reason at all...These people just want what was advertised when they purchased, they don't care what format its in as long as you help.

Share this post


Link to post
Share on other sites

The RMT_INIT routine is at $7C00, there is a call somewhere in the program that has the song address at $0000. The call address is not exact as there are several different builds out there. This was intended to stop the music from playing after a piece was played once. I removed this second call in the updated version, and added an extra track to RMT so it loops over an empty song line. I was not fully aware of how to do things with RMT until I started to port songs for Secretum Labyrinth. I had to hack the song KJMANN provided for Venture to add that empty song line loop. Whatever people do with this information is up to them, and they will be on their own as we only support the game being played from cartridge.

Share this post


Link to post
Share on other sites

Pete, I sent an email to Video61 a couple of days ago and got a friendly and helpful reply in return. Unfortunately, things have been pretty busy around here this week so I have been putting off getting back to him. I hope to do so either later today or by Tuesday at the latest (whenever my computer is free :)).

 

And to let everyone else know, both Pete and Lance at Video61 seem committed in helping my solve my cartridge problem. Thank you to both of them.

  • Like 4

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...