Jump to content
InsaneMultitasker

Horizon RAMdisk ROS and CFG Development

Recommended Posts

32 minutes ago, dhe said:

SNUG has it's own software.

 

Thanks.

The only .DSK I found in my snug directory is the "ROS8.14-F16". This one ?

And there are some HRD16*.P99-files which I don´t know to handle, and that are not mentioned in the manual.

 

 

 

Share this post


Link to post
Share on other sites

 

Sorry, can we switch this SNUG-question to the snug topic, not to pollute the Horizon-topic here ? thx

 

(I asked the same question there)

->

 

Share this post


Link to post
Share on other sites

From what I recall, the snug ramdisk is HRD4000 software compatible.  I do not know if the SNUG group modified ros or created their own DSR?  Perhaps those who are more familiar with the snug cards, like Atrax or Ksarul, can shed light on your question.

  • Thanks 1

Share this post


Link to post
Share on other sites

I use CFG/ROS from this thread on both my HRD16 AND Horizon 2000 and have for years without any problems at all. The HRD16 is essentially a Horizon RAMdisk with a few tweaks for stability and efficiency. It also has a 16-bit mode when used with the SGCPU. The most notable is the Lithium battery. The batteries in my SNUG cards (BWG and HRD16) both lasted 15+ years before they needed to be replaced.

 

The .P99 files on the SNUG site are binary files with an added TIFILES header.

Edited by atrax27407
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Hi,

 

OK, I got it managed to change the battery on my Snug HRD16 3MB without destroing my whole system.

And I was able to "socket" it with a battery holder, to easily reset it.

I´ll tell you more when the fire department has left my house :grin:

 

So I tested my HRD16 (first time I use a HRD!) with playing around.

First I tried to use the newest CFG here around (3-27-2020), it recognizes the card,

but if I try to load the ROS(ticc) I just get "error".

 

Then I tried the former, usual 8.14-F disk, this completly seems to work.

I can create drives an letters, and copy files a.s.o.

 

Then I "resetted" the card again (by pulling the battery and waiting a moment), and it seemed to be deleted.

Then again, I used the new CFG, given here, and loaded the ROSTICC from the 8.14-F with it. This work too :thumbsup:

So, if there is a problem, and it´s not me, it should be the new ROS, right ?
 

I think, this is not dramatic, as the HRD16 works with the older ROS at all,

but if you want to add or fix the collaboration with the HRD16, i can offer doing dirty things remote here ;)

or I can ship my HRD16 to you, if you want. But only, if it makes sense at all, to "fix" that.

And, maybe the "problem" is due to my card here ? Possible too, of course.

 

thx

xXx

 

 

 

 

 

 

 

 

 

 

 

 

Edited by Schmitzi
  • Like 1

Share this post


Link to post
Share on other sites

I have had no problems using CFG1/2 and the new ROS842C on my HRD16. You must not "mix and match" CFG and ROS files. There is now only one ROS file instead of variants for the Myarc and TICC controllers. Unless you have a bad download, CFG1/2 should load ROS842C flawlessly. Send me a PM.

  • Like 1

Share this post


Link to post
Share on other sites

Hi, i used the newest download. The "mix" was just a later test, to see on what it depends.

 

 

 

Share this post


Link to post
Share on other sites

Hi, it´s the BWG-Controller with an Lotharek drive.

I wil try a new download tonight, and convert a new HFE maybe, but I never had problems with that conversion.

 

Share this post


Link to post
Share on other sites

The Lotharek drive might very well be the problem. I have a BWG in my system and there are no problems using it to load CFG1/2 and ROS842C. I am loading ROS from a real floppy drive and CFG1/2 from the HRD16.

Share this post


Link to post
Share on other sites

Mountet the DDCC-1,

from DSK1 (Lotharek) is says "Error"

from DSK3 (5.25") brings "Error 7"

 

Then I mounted an original TI Controller,

from DSK1 it says "Error" (like all others)

from DSK3 it resets to the titlescreen

 

Maybe I have to dismount the Lotharek, I´ll try that later this evening

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

Good evening :-D

 

I mounted another TI controller and one (another) 5.25" drive

Same Error:

 

IMG_2533.thumb.jpg.8134124f2ac033df029987d2e42ccd50.jpg

 

IMG_2534.thumb.jpg.d93ed97737bd93bc7922226d4b03f9f5.jpg

 

IMG_2535.thumb.jpg.6072fa854a20ea2cb921e06bedec966c.jpg

 

IMG_2536.thumb.jpg.093da0a7423e5e49cd8e87c547d85a77.jpg

 

IMG_2537.thumb.JPG.8c5660945bdf22616396ba91b014ae6c.JPG

 

 

 

Edited by Schmitzi

Share this post


Link to post
Share on other sites
Posted (edited)

With the 8.14-F

(BWG/Lotharek,

 and also new CFG842C from Lotharek and old "ROSTICC" 814-F file from DSK3 Floppy drive)

 

IMG_2527.thumb.JPG.53a6647e6baf5b5d70b673048c2c53cc.JPG

 

Maybe the ROSTICC file (8.42C 3-27-2020) inside the HFE is corrupt ? hmmmmmm

Would be the first time since years. I´ll download & convert again tomorrow...

 

 

Edited by Schmitzi

Share this post


Link to post
Share on other sites

 

 

AAAH, one more hint: This is an F18A machine, I can also take another Console tomorrow

Share this post


Link to post
Share on other sites

I did my testing with F18A machine.  There is no ROSTICC in 3-20-2020.

 

What is the filename:  "ROS842" or "ROS842C"?   Make sure your filename is right and case sensitive, etc. 

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, InsaneMultitasker said:

I did my testing with F18A machine.  There is no ROSTICC in 3-20-2020.

 

What is the filename:  "ROS842" or "ROS842C"?   Make sure your filename is right and case sensitive, etc. 

 

yeah, ROSTICC is just how I call them, both. It happened as shown in the screens above. 842c ? The name was given, I just pressed enter.

 

My F18A 🥰 is latest firmware, I think (v1.8 IIRC)

 

Edited by Schmitzi

Share this post


Link to post
Share on other sites
Posted (edited)

 

ah OK, I checked the .DSK and the name of the file is different than the given default name, it´s ROS842CC.

And "error" means file not found.

I have to check later, when I am back. This is it, I think :) :thumbsup: thx

 

Edited by Schmitzi
  • Like 1

Share this post


Link to post
Share on other sites

Yes.  When I made the ZIP I noticed in Fred's program that the TI filename was different than the PC filename.  I think this has to do with how I am using xdt99.   I meant to figure out the problem and never did.  So if you transfer to disk image the name might be "ros842cc".   however, if you load from TIPI (as I do) you use the PC name.  Up until now I've always distributed with disk images so I am learning too!

 

Maybe I will remove the default ROS name from the CFG program so that everyone has to type it :)   I'll also consider whether or not I can add a 'file not found' message instead of 'error'. If/when I release another version.   ;)

 

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

FYI, I ALWAYS type in the filename. I don't necessarily trust that the default on the screen will match the one on the disk. Also, I'm prone to rename files on disk from time to time.

Edited by atrax27407
  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, Schmitzi said:

IMG_2527.thumb.JPG.53a6647e6baf5b5d70b673048c2c53cc.JPG

 

ugh. what a mess. what was i thinking back then. -- too busy, too crowded, i like the OPA logo that is about it. :)

 

 

 

  • Like 3

Share this post


Link to post
Share on other sites
6 hours ago, InsaneMultitasker said:

Back then I thought the MUG logo (MENU) and ROS title (above) were really cool!  First time I saw those alterations it blew my mind :)

 

Yes ! Absolutely same same, an this happened to me yesterday :lust:

Share this post


Link to post
Share on other sites
22 hours ago, InsaneMultitasker said:

Yes.  When I made the ZIP I noticed in Fred's program that the TI filename was different than the PC filename.  I think this has to do with how I am using xdt99.   I meant to figure out the problem and never did.  So if you transfer to disk image the name might be "ros842cc".   however, if you load from TIPI (as I do) you use the PC name.  Up until now I've always distributed with disk images so I am learning too!

 

Maybe I will remove the default ROS name from the CFG program so that everyone has to type it :)   I'll also consider whether or not I can add a 'file not found' message instead of 'error'. If/when I release another version.   ;)

 

 

 

So I used the correct filename now (ROS842CC) and the ROS loads :)

 

One thing that I see is, if I set the "Power Up" parameter to "Yes", then, at restart, I only get a light blue screen.

I found out that this is due to the FinalGROM99 usage (TI XB or XB2.5 loaded, or whatever)

If I use a real iron Extended Basic cartridge, the system starts up......

 

So I pulled an old HRD3000 card (1 MB, all tests = OK) and it´s the same behaviour.

No reaction after loading the ROS if the FinalGROM is inserted

 

I also switched the HRD3000 to >1400 and loaded the original 8.14-F with an Extended Basic cart,

this is OK, until I insert the FinalGROM99. Then after power up the TI (with parameter "Power up=Y), only a light blue screen

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Is the file MENU on your first formatted ramdisk?  Try that and see if it resolves the issue. 

 

I do not use a finalgrom/finalrom so I do not know what is happening. Does finalgrom have its own powerup routine that tries to take control?  It is possible that without the MENU program on the ramdisk, the return code is getting lost on its way back to finalgrom.  (conjecture)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...