Jump to content
Sign in to follow this  
sparkdrummer

US ROBOTICS V.90 56K MODEM

Recommended Posts

I am trying to hook up a US Robotics modem to my TI system so I can do a little local BBS'ing (HEATWAVE).

The model is 0701.

 

Can this modem work with a TI? I have tried a few things but have pretty much forgot how to hook a modem up successfully.

 

The software I'm using is TERM80, which is the last I used when I did BBS'ing back in the day.

 

Any help is much appreciated.

 

-sparkdrummer

Share this post


Link to post
Share on other sites

As long as it's not a WinModem you should be fine (and I think Winmodems only came as internal cards anyway!)

 

You may need to check that the dip switches are sensible (USR still has manuals for download), and depending on your system higher speeds may have trouble with it. Start around 2400 bps and work up, rather than starting high and working down. (ISTR some cards not talking to PC devices at higher speeds due to poor timing).

 

You need the opposite kind of cable a PC would use (I've confused myself and forgotten which is which - I think you DO need crossover for the TI) and in the default hardware configuration, you will have no hardware flow control and will need to turn that off. A null modem adapter may set you straight on the cable. ;)

 

That should be enough to talk to the modem and dial a BBS, though... for more advanced than that I think we still have a few here who do it! ;)

Edited by Tursi

Share this post


Link to post
Share on other sites

Is there also a special cable required to mate an EIA/RS-232 modem to the TI as the TI is wired as a DCE?

Share this post


Link to post
Share on other sites

I am trying to hook up a US Robotics modem to my TI system so I can do a little local BBS'ing (HEATWAVE).

The model is 0701.

 

Can this modem work with a TI? I have tried a few things but have pretty much forgot how to hook a modem up successfully.

 

The software I'm using is TERM80, which is the last I used when I did BBS'ing back in the day.

 

Any help is much appreciated.

 

-sparkdrummer

 

 

Yes that's what i have on my TI/geneve you'll have to make your own modem cable or use an autohandshake box (what i have)

 

best is to hook up send, receive, ground, dtr and rts properly .. for flow control.. on a 99/4a the best you will get with a term program on a ti or corcomp card is about 9600 baud before you start overrunning the 9902.. on a geneve you can get up to 19200 baud

 

Greg

Edited by arcadeshopper

Share this post


Link to post
Share on other sites

 

 

Yes that's what i have on my TI/geneve you'll have to make your own modem cable or use an autohandshake box (what i have)

 

best is to hook up send, receive, ground, dtr and rts properly .. for flow control.. on a 99/4a the best you will get with a term program on a ti or corcomp card is about 9600 baud before you start overrunning the 9902.. on a geneve you can get up to 19200 baud

 

Greg

 

I think with term80 it has docs for making a cable with flow control in the manual.. you might get up to 19200 on the 99/4a :)

 

Greg

Share this post


Link to post
Share on other sites

Technically you /should/ make a proper cable, but I have many times just run a modem using a 25-25 PC cable and a NULL modem adapter to do the crossover. :) As I noted, though, no flow control in that configuration. I was only running 2400 bps back then, it didn't really matter. :)

Share this post


Link to post
Share on other sites

I'm not sure if the dip switches are set correctly to couple with the ti. I believe I have them set to a default setting. I see two of the LEDs light when I try a atdt command, but I get no response back on the screen. The cable I'm using I marked years ago "modem" but that's no guarantee it will work with this modem. Thanks for your help on this guys.

Share this post


Link to post
Share on other sites

I'm not sure if the dip switches are set correctly to couple with the ti. I believe I have them set to a default setting. I see two of the LEDs light when I try a atdt command, but I get no response back on the screen. The cable I'm using I marked years ago "modem" but that's no guarantee it will work with this modem. Thanks for your help on this guys.

 

if you have the hdx mod on your rs232 you need to enable interrupts .. if not then it sounds like you have a poorly wired cabel OR your baud rate isn't being sent correctly to the usr.. try at 1200 or 2400 baud 8n1

Edited by arcadeshopper

Share this post


Link to post
Share on other sites

If the sending system is outputting at high speed, most TI terminal emulators start failing at 4800 and are rendered unusable at 9600. Unfortunately, the TI's interrupt routine and buffering mechanism are very inefficient. Direct polling works but it takes a lot of effort to streamline the code enough to avoid missing incoming characters.

 

To improve throughput, I would like Fred to offer a modification to his HDX DSR that would allow you to use the secondary card for HDX. This way, terminal programs wouldn't need to be bogged down checking the first card for every pending interrupt.

 

PORT for the Geneve is written to handle 38,400 with interrupts, primarily because I over-ride the OS interrupt routine with one that favors the RS232 port you are using, among other things. Hardware handshaking is technically only required for color ANSI, since to emulate color on the V9938 requires massive VDP overhead. The V9938 doesn't have a native 80-column color text mode, so graphics mode is used to draw each character. One full screen is nearly 60,000 bytes versus what could have been 4000 bytes (screen + attribute tables). So sad.

  • Like 1

Share this post


Link to post
Share on other sites

Technically you /should/ make a proper cable, but I have many times just run a modem using a 25-25 PC cable and a NULL modem adapter to do the crossover. :) As I noted, though, no flow control in that configuration. I was only running 2400 bps back then, it didn't really matter. :)

 

What Tursi mentioned has also worked for me with my "newer" (15 years old) v.90 USR faxmodem. Just a straight-through cable with a null-modem adapter on the end and everything works fine. Since you seem to have a similar modem I would say try that first for simplicity. If everything is cabled correctly, the TR light on your modem should illuminate once you load a terminal program. If you cannot type AT commands while in your terminal program, then something is not cabled correct.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...