Jump to content
Sign in to follow this  
jcbstein

65XE/130XE modification

Recommended Posts

I'm assuming that's a PAL 65XE from Europe. That's actually factory.

 

As I understand it they ran out of the right size of chips and replaced with another chip that had more pins than the socket, necessitating the need for that lovely mess.

 

I got this information directly from Mr Atari when I purchased one from his old webshop.

Share this post


Link to post
Share on other sites

Yep,

 

I have seen this mess on many of the newer PAL XE models (most of them made in China, thus with faulty GTIA chip). They did run out of 8k (Atari Basic) ROM chips with fewer pins it seems... and yes, this mess was factory made...

Share this post


Link to post
Share on other sites

The unit was used with the Spectraview II Cartridge. Or at least I believe it was. It works nicely on my Monitor. I take it this wont work on the my tv then?

Share this post


Link to post
Share on other sites

Does it make a rainbow pattern when you power up? If so, that's Spec-1 not 2.

 

Edit: Spec-2 does not require the BASIC chip mod.

 

If BASIC comes up, then it's most likely factory.

Edited by Kyle22

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...