Jump to content
Newsdee

Retro Freak firmware update

Recommended Posts

Sorry, actually I meant that you can use ROMs that you have from other places, but I think they need to be in the same folder on the SD card. You distinguish them by file extension.

 

Thanks, so you can put the roms anywhere on the sd card then? so all the roms go in 1 folder? does the folder have to have a name or will any name do?

 

Thanks

Edited by Odin Belmont

Share this post


Link to post
Share on other sites

Thanks, so you can put the roms anywhere on the sd card then? so all the roms go in 1 folder? does the folder have to have a name or will any name do?

Thanks

I think it's a specific folder. I don't have my unit with me right now, but easiest way is to dump one cart and see where it lands... Edited by Newsdee

Share this post


Link to post
Share on other sites

I think it's a specific folder. I don't have my unit with me right now, but easiest way is to dump one cart and see where it lands...

 

 

Received Console today. All working great. Updated to Version 2.0 all went well. Extremely happy with it. Dumped a few games and then copied over 25gb on games and all work amazing.

 

Retro Freak is a amazing little console.

 

Thanks for helping :)

  • Like 1

Share this post


Link to post
Share on other sites

I have a deluxe retrofreak (includes the classic controller module) at firmware 2.0 for sale - if anyone is interested $160CDN + shipping - send me a message if interested instead of replying to me in this post.

 

Kinda off topic but I also have a gpd 32g in black and a snes mini with the Stoneage gamer deluxe sd2snes for sale.

Edited by Dragun

Share this post


Link to post
Share on other sites

Looks like there's an international version of the Retro coming out which includes a NES adapter. Maybe now somebody will figure out a way to run CD games.

Share this post


Link to post
Share on other sites

Looks like there's an international version of the Retro coming out which includes a NES adapter. Maybe now somebody will figure out a way to run CD games.

Care to cite this? If so, that's awesome. Hopefully they update the cheats database to be bilingual.

Share this post


Link to post
Share on other sites

It's on preorder at play-asia:

http://m.play-asia.com/retro-freak-controller-adapter-set/13/70ahih

 

There's a cheaper version without the controller adapter too.

Okay so they're just throwing in an NES converter. I got some of those already. I wish I could find a controller adapter for mine though. I bought the standard edition. :P

Share this post


Link to post
Share on other sites

Firmware 2.3 is available now - see: http://www.cybergadget.co.jp/support/retrofreak/update/

 

However I am having problems installing it.

 

I have version 1.5 firmware installed and only just now getting time to try to update beyond that.

 

After going through the normal cycle of writing request file to the SD card, uploading it to cybergadget and downloading the firmware update I get the following error message:

 

"Installation failed - error code: 1000"

 

I can't seem to find any reference to this error. Anyone else seen this problem or similar?

 

Things I have tried:

- Disconnect the main RetroFreak from the cartridge adapter (and all other adapters)

- Multiple Micro-SD cards

- Reinstalling 1.5 which seems to work

 

Additional information:

- On 1.5 it does not seem to remember my language, acceptance of license agreement or monitor settings. It asks me to set these every time I turn it on. Not had this on previous firmwares

- Otherwise everything is working fine

- System Information shows: RetroFreak application: v1.5 (build 2764), System software: v0.2.0, Hardware revision: v1.0

 

Does anyone know a link where I can request an earlier firmware in case its just 2.3 thats the problem? Never had issues before in updating the firmare.

 

Any ideas of other things to try?

 

Thanks in advance!

Share this post


Link to post
Share on other sites

I can't even update to 1.5. I just got my unit in yesterday, and am stuck on 1.4. After the countdown timer disappears, the system gets stuck. All I see is the background image. I tried disconnecting the unit, unplugging it for a while, etc., but nothing's working. Anyone else run across this?

Share this post


Link to post
Share on other sites
Guest LiqMat

The only older firmware file I have is "RetroFreak-SystemUpdate-0.2.0.zip". Is this the one you guys have? Once unzipped the image file "retrofreak-system-update.img" should be 173,462,016 bytes. This worked fine for me. I do not own the RF anymore, but if you need this file let me know.

 

I know with other retro systems and floppy emulator SD card readers sometimes the type of SD card can screw up the updates. I used a SanDisk Extreme Pro 32GB SDHC card and updated the firmware without issue. I ran across various floppy emulator SD card readers that refused to update firmware properly if using a SDHC or higher card, but if you installed the firmware from a standard SD card like a 2GB SD card the firmware update worked great. None of this was documented at the time either. You could try that and let us know.

Edited by LiqMat

Share this post


Link to post
Share on other sites

The only older firmware file I have is "RetroFreak-SystemUpdate-0.2.0.zip". Is this the one you guys have? Once unzipped the image file "retrofreak-system-update.img" should be 173,462,016 bytes. This worked fine for me. I do not own the RF anymore, but if you need this file let me know.

 

I know with other retro systems and floppy emulator SD card readers sometimes the type of SD card can screw up the updates. I used a SanDisk Extreme Pro 32GB SDHC card and updated the firmware without issue. I ran across various floppy emulator SD card readers that refused to update firmware properly if using a SDHC or higher card, but if you installed the firmware from a standard SD card like a 2GB SD card the firmware update worked great. None of this was documented at the time either. You could try that and let us know.

Yep, that's the file I've been trying to use. That particular update is still on the Retro Freak support site under its own section. (Thanks anyway for the offer!) I'm using a Samsung SD card. I was able to update from the default version to 1.4 with the card, but for some reason, going from 1.4 to 1.5 just isn't happening. That's the only Micro SD card that I own, but I'll try to find a smaller-sized one and give it a shot.

Edited by entryan

Share this post


Link to post
Share on other sites

Thanks entryan and Liqmat - have tried an old plain SD micro SD 1GB card and two more recent SDHC 16GB and 32 GB cards (the 32GB straight fresh from the packet Samsung brand one) No luck.

 

I might see if I can somehow factory reset all settings and see if that helps. Since it's otherwise working fine I have been holding off doing anything too drastic, but seems others not having the same issue so got to try something.

 

Will post back here if I have any luck or learn anything more.

 

Thanks again for trying to help :-)

Share this post


Link to post
Share on other sites

Tried a couple more things - still no luck.

 

Found links to download v1.6:

http://retrofreak.in/ja?src=17e62166fc8586dfa4d1bc0e1742c08b

 

and v2.0:

http://retrofreak.in/ja/?src=072b030ba126b2f4b2374f342be9ed44

 

and tried updating with those. Same issue "Installation failed - error code: 1000"

 

Also can't seem to find any "factory reset" type option, so I'm running out of things to try :-(

 

Anyone got a direct contact for CyberGadget support which may be able to help?

Share this post


Link to post
Share on other sites

It's a long ahot but you could try asking on their website. They seem to be preparing an international version (play-asia preorder) so they ought to have some English support at some point...

Share this post


Link to post
Share on other sites

I havent upgraded my Rfreak or played it in a month of Sundays. I think v1.5 was the latest OS I installed on it, but was working great last I played with it. Should I attempt to upgrade the OS or leave well enough a lone? After all, if it ain't broke, don't fix it! :cool:

Share this post


Link to post
Share on other sites

I heard back from Cyber Gadget, and it turns out that my problem is hardware related. They suggested sending it back to the retailer to get fixed: "Unfortunately, it is highly likely that the problems you are experiencing are the hardware failure. However, we sell our products only in Japan and our warranty is valid only for the products purchased and used in Japan. Therefore, we are unable to repair or return the product to other countries. We would suggest to take them back to where you got it and ask them what they can do." Fortunately, I bought it through Amazon, so that's not a problem. I think I'll wait until they add the NES adapter before I give it another go.

Edited by entryan
  • Like 1

Share this post


Link to post
Share on other sites
Guest LiqMat

I heard back from Cyber Gadget, and it turns out that my problem is hardware related. They suggested sending it back to the retailer to get fixed: "Unfortunately, it is highly likely that the problems you are experiencing are the hardware failure. However, we sell our products only in Japan and our warranty is valid only for the products purchased and used in Japan. Therefore, we are unable to repair or return the product to other countries. We would suggest to take them back to where you got it and ask them what they can do." Fortunately, I bought it through Amazon, so that's not a problem. I think I'll wait until they add the NES adapter before I give it another go.

 

Wow. That really sucks some bad units went out like that.

Share this post


Link to post
Share on other sites

I heard back from Cyber Gadget, and it turns out that my problem is hardware related. They suggested sending it back to the retailer to get fixed: "Unfortunately, it is highly likely that the problems you are experiencing are the hardware failure. However, we sell our products only in Japan and our warranty is valid only for the products purchased and used in Japan. Therefore, we are unable to repair or return the product to other countries. We would suggest to take them back to where you got it and ask them what they can do." Fortunately, I bought it through Amazon, so that's not a problem. I think I'll wait until they add the NES adapter before I give it another go.

 

I had the same issue you're having and I got the same response from Cyber Gadget. As I live in Brazil and I couldn't reach the Amazon seller, I insisted with them and they agreed to repair my RF unit. The only issue: I had to send the main unit to Japan. So I sent it to a friend who lives there and sent my Retrofreak to the factory. 4 weeks later, they sent it back to my friend. Just a week ago, my friend sent the unit back to me here in Brazil. They not only repaired, but also updated to the v2.0 firmware. Got tell you that now I'm relieved but also kind of afraid of the problem repeating itself when trying to update to the v2.3.

 

 

Share this post


Link to post
Share on other sites
Guest LiqMat

 

I had the same issue you're having and I got the same response from Cyber Gadget. As I live in Brazil and I couldn't reach the Amazon seller, I insisted with them and they agreed to repair my RF unit. The only issue: I had to send the main unit to Japan. So I sent it to a friend who lives there and sent my Retrofreak to the factory. 4 weeks later, they sent it back to my friend. Just a week ago, my friend sent the unit back to me here in Brazil. They not only repaired, but also updated to the v2.0 firmware. Got tell you that now I'm relieved but also kind of afraid of the problem repeating itself when trying to update to the v2.3.

 

 

 

Would not worry too much. If you have a working unit updates will go smoothly. My unit updated every time perfectly and without issue.

Share this post


Link to post
Share on other sites

I heard back from Cyber Gadget, and it turns out that my problem is hardware related. They suggested sending it back to the retailer to get fixed: "Unfortunately, it is highly likely that the problems you are experiencing are the hardware failure. However, we sell our products only in Japan and our warranty is valid only for the products purchased and used in Japan. Therefore, we are unable to repair or return the product to other countries. We would suggest to take them back to where you got it and ask them what they can do." Fortunately, I bought it through Amazon, so that's not a problem. I think I'll wait until they add the NES adapter before I give it another go.

I got the same thing from CyberGadget eventually. I contacted my Hong Kong based retailer and they weren't very helpful (told me I was out of warranty because they bought it from Cyber Gadget more than 1 year ago - even though I bought from them less than 1 year ago and was supposed to be 1 year warranty! Typical for HK unfortunately).

 

Managed to talk them around a little bit and they gave me a good price on a replacement unit which seems to work fine and updated just now to 2.3 without issues. Really disappointed the first unit went bad. I always treated it with kid gloves and it upgrade all the way from 1.0 to 1.5 without issues but got stuck there.

 

Anyway, back happily RetroFreaking and now I can use my RetroFreak Gear Converter GG/MKIII/SG cartridge adapter finally after a kind friend got it from Japan for me (which is what prompted me to upgrade the firmware in the first place!).

 

Thanks to everyone who gave me very helpful suggestions to fix the first one!

Share this post


Link to post
Share on other sites

Curious If any other Retro Freak owners have had an overheating issue, and if so have any of the firmware updates actually remedied the issue?
Im in the middle of a creative project to add heatsinks and a cooling fan to the unit. Needless to say im extremely dissapointed with the design of the system.
This system is too expensive and very time consuming to import only to brick it by overheating the unit.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...