Jump to content
Sign in to follow this  
ralphb

CALL SAY things

Recommended Posts

I'm trying to say some things with CALL SAY in XB, but it's not working at it should. For example,

CALL SAY("READY TO START")

just spells out READY and continues with "TO START". CALL SAY in conjunction with CALL SPGET

CALL SPGET("READY TO START", R$)
CALL SAY(,R$)

just says "uh-oh" (both on real iron).

 

READY TO START is listed as an available word in the XB manual. Is this a mistake, or do I need to specify that phrase differently?

 

(I know there's Text-To-Speech, but I probably need the output sooner than I learned that tool.)

 

 

Share this post


Link to post
Share on other sites

Duh, thanks!

 

BTW, is your Speecoder available somewhere right now, as your home page is under maintenance?

Share this post


Link to post
Share on other sites

BTW, the Speech Editor manual has some really important information about CALL SAY and CALL SPGET. Unfortunately, TI seemed to have forgotten to copy those texts to the Extended Basic manual. I do not remember where I got that hint about "#", but at least the Speech Editor manual has it. Also, the "#" should possibly appear at the end as well, but this is obviously not checked.

 

SPEECODER is available somewhere here on the forum, may have to search.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...