Jump to content
Marsupilami

Help: Dumping Cartridges for dummies

Recommended Posts

I made a video to show how its done


Nir

 

Nir your video not appear anymore online. I hope to not reported as illegal from some heat head!

Edited by santosp

Share this post


Link to post
Share on other sites

I convert the .rom file to .car, and load it on eclaireXL within cartridge loader.

The cartridge load normally, and choosing the "I" option I see in my screen "Gerat nicht angeschlossen - Prufen!" message.

Not some error.

Thanks @santop. That's the "error" message it should gives (the one with the real cartridge on a real 800xl).

But it's not the message i have in Altirra so i guess Altirra (windows version) is a bit sensitive with the .ROM file.

At least your test shows that my dump is good :)

Edited by Marsupilami

Share this post


Link to post
Share on other sites

Thanks @santop. That's the "error" message it should gives (the one with the real cartridge on a real 800xl).

But it's not the message i have in Altirra so i guess Altirra (windows version) is a bit sensitive with the .ROM file.

At least your test shows that my dump is good :)

 

The crash with the garbage at the bottom appears to be a bug in the cartridge that manifests if you have the H: device enabled in the emulator and have also enabled the non-default option to also install it as D:.

 

The bug is that the cartridge's init routine checks for a D: device, and if it finds one, attempts to patch it. Problem is, it revectors D: in HATABS to garbage in the middle of the ROM, which causes a crash. This is done at the same time that E: is patched, so it was probably a remnant of an early attempt at putting DOS on-cart. If you boot DOS off of a disk, this doesn't happen because DOS adds the D: device after cartridge init has occurred. But if it's already there... kaboom.

Share this post


Link to post
Share on other sites

Hi Marsupilami,

 

To my mind, you have done everything right, have taken your rom dump and a DOS II 2.0S disk from Atari (which is written in the manual, of course in German) everything works like a charm with the Atari800MacX emulator on a Mac with 400/800 system, XL and XE. But the disk has to be inserted, before the cart starts. With you incredible help, please see the credits, I was able to finish the Schreiber site yesterday:

https://atariwiki.org/wiki/Edit.jsp?page=Atari%20Schreiber

 

Remaining is just: does the cart take 8 KiB oder 16 KiB?

 

This is the picture, when everything is o. k.:

[attachment=579831:DIR.jpg]

 

and this will occur, when, when the Schreiber disk (ATX image) is inserted, starting was from this disk and then made the "Inhaltsverzeichnis":

[attachment=579832:garbage.jpg]

 

If you take away the SCHREIBER disk and insert a DOS II 2.0S disk, everything is o. k. :-)

 

So, you see Marsupilami, you have done everything all right, as always, it is just that German language... Will pass away...

Edited by luckybuck

Share this post


Link to post
Share on other sites

Ok Thanks, to both of you, Phaeron (i trully always enjoy your detailed explanations because i learn things) and luckybucky. 

Share this post


Link to post
Share on other sites

Nir, what happened to the 64K dumping video?

 

I was interested in that little card adapter you made...Just to see what it does...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...