Jump to content
atari2600land

the official Channel F thread!

Recommended Posts

2 hours ago, jgkspsx said:

Does anybody know who owns the rights to the Channel F and its games? Is it still Zircon (https://www.zircon.com)? The Evercade folks expressed interest in releasing a Channel F compilation for the Evercade, and that would be amazing!

I asked Zircon once, wasn't able to squeeze a reply out of them. 
Considering the Multi-Cart I decided not to ask again, would be quite crappy if they got involved claiming rights.

Great for Evercade if they get/pay for permission, probably bad for everyone else. 

  • Like 1
  • Sad 1

Share this post


Link to post
Share on other sites

Have been messing around with coding for the Channel F over the last few days, it's great fun! I've been writing C64 games for the last 18 months or so and was looking for a new challenge, and coming from the elegant simplicity of the 6502 with the power of the VIC & SID, the F8 certainly offers that.

 

I've been porting one of my simpler C64 games from the 4K Cassette 50 competition and the gameplay is done, just need to implement scoring and level transitions, maybe a title screen if I can be bothered! I'll share the .bin and source when it's done. 

 

One thing I can't seem to make any headway with though is sound, MESS doesn't seem to do anything apart from a few clicks and pops. I tried build 31 of Pacman and that has no sound either. Is this a known thing?

Share this post


Link to post
Share on other sites
6 minutes ago, Arlasoft said:

Have been messing around with coding for the Channel F over the last few days, it's great fun! I've been writing C64 games for the last 18 months or so and was looking for a new challenge, and coming from the elegant simplicity of the 6502 with the power of the VIC & SID, the F8 certainly offers that.

 

I've been porting one of my simpler C64 games from the 4K Cassette 50 competition and the gameplay is done, just need to implement scoring and level transitions, maybe a title screen if I can be bothered! I'll share the .bin and source when it's done. 

 

One thing I can't seem to make any headway with though is sound, MESS doesn't seem to do anything apart from a few clicks and pops. I tried build 31 of Pacman and that has no sound either. Is this a known thing?

Sounds really cool. I will unashamedly rip your source code in the hopes of understanding enough to produce something useful myself one day. 

 

Regarding mess, I have a MESSy time with it myself. Which version are you using? I find one (and I think it's an older version) works flawlessly while the newer one doesn't work for me at all. I can have a look and see what version I have later too. 

Share this post


Link to post
Share on other sites
6 minutes ago, Mikebloke said:

Sounds really cool. I will unashamedly rip your source code in the hopes of understanding enough to produce something useful myself one day. 

 

Regarding mess, I have a MESSy time with it myself. Which version are you using? I find one (and I think it's an older version) works flawlessly while the newer one doesn't work for me at all. I can have a look and see what version I have later too. 

 

Haha, well to be fair I'm making liberal use of the draw tile and blit functions from Pacman and Tetris. I'm also using macros and labels for a lot of stuff to make the code more readable, for instance the 7 instructions needed to increment a value in an array with the index in the accumulator just becomes 'Decrement_Indexed_Ram RAM.Grid'. 

I'm not even sure which version of MESS I have, when I go to the about page it freezes...!

Edited by Arlasoft

Share this post


Link to post
Share on other sites

The Channel F doesn't really have much in the way of sound. All it can produce is the clicks you mentioned, except for the music code. If you want it to play a tune, you need to pause everything else.

Share this post


Link to post
Share on other sites
4 minutes ago, atari2600land said:

The Channel F doesn't really have much in the way of sound. All it can produce is the clicks you mentioned, except for the music code. If you want it to play a tune, you need to pause everything else.

Yeah the emulator doesn't seem to be doing anything in the way of sound, no tunes in Pacman, no beeps. Sometimes a pop or click if I'm lucky.

Share this post


Link to post
Share on other sites

Some comments.

The cursor moves way too fast. Could you slow it down?

When you reset the game, the picture is red and green instead of black and white.

Nice sound and graphics.

Share this post


Link to post
Share on other sites
4 minutes ago, atari2600land said:

Some comments.

The cursor moves way too fast. Could you slow it down?

When you reset the game, the picture is red and green instead of black and white.

Nice sound and graphics.

What emulator are you playing on? I debounced the inputs which seemed to work on my version of MESS but had trouble with other emulators. 

 

I'll sort the reset thing, easy fix.

Share this post


Link to post
Share on other sites

 

3 minutes ago, atari2600land said:

I'm playing on MESS 0.211.

What keys have you got mapped? I saw on another emulator the cursor just skips all the way in the direction you press, but on MESS 0.231 it seems fine. This is on a VM in Parallels though so I'll try it on a Windows laptop.

Share this post


Link to post
Share on other sites

That's what I'm talking about: The cursor skips all the way in the direction you press. I've got the arrow keys mapped up for the joystick.

Share this post


Link to post
Share on other sites

I have a possible solution:

Code it so when the player moves, it only moves one square until the joystick isn't pressed, and then allow the player to move again when the joystick is at neutral.

Share this post


Link to post
Share on other sites
11 minutes ago, atari2600land said:

I have a possible solution:

Code it so when the player moves, it only moves one square until the joystick isn't pressed, and then allow the player to move again when the joystick is at neutral.

That's exactly what it should have been doing, I've made a change and attached - when you get a chance please could you let me know if it works.

game.bin

Share this post


Link to post
Share on other sites

 

10 minutes ago, atari2600land said:

No, it still does what it did before.

I re-wrote the input code I'd lazily copied from Veswiki, I'd forgotten to debounce the controllers separately. Should work now, it works on this online emulator: https://www.lexaloffle.com/bbs/?pid=71273

 

game.bin

Edited by Arlasoft
Replaced bin - random levels were broken

Share this post


Link to post
Share on other sites
1 minute ago, atari2600land said:

Yes, this works good.

Great, thanks for trying it out. The initial rom I put in that post had the procedural levels broken, I was bashing a counter register in the debounce code.

Share this post


Link to post
Share on other sites
2 minutes ago, atari2600land said:

I thought this puzzle was awfully easy:

0083a.png.175554149174e648b5f3ae70c7597668.png

Haha yeah, I suppose I could make the level generator try again if it fails to place enough trees - at the moment it only tries again if it didn't place any. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...