Jump to content

Recommended Posts

I recently rescued a Vectrex from a crumbling abandoned building. After i had replaced the cord, i figured out it does not work. There is no sound but the normal humming. Does anyone know if i could repair this?

post-63559-0-45581900-1523654134_thumb.jpg

Share this post


Link to post
Share on other sites

Of course it can, but you may have to do it yourself. Very few people know much about it, and it seems there are a variety of problems these machines end up with. At least you know the beam is bright, so you've got something to work with. Check out tutorial videos...

Share this post


Link to post
Share on other sites

You can carefully start by doing a full cap replacement and go from there. Be careful though as the boards are really cheap and are easy to damage when soldering.

Share this post


Link to post
Share on other sites

So, after I replaced the capacitors, it still looks like this. I have no idea where to go with it now. It has no sound, but a bit of the humming. I’m officially lost. Is there some where I can send it to get it repaired?

image.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...