Jump to content

Recommended Posts

post-30777-0-82389000-1543298608.jpg

Working on patching a couple of games to run on the Flashback 9, thought this would be a good thread to keep track of patching incompatible ROM's and share ideas on making new games more compatible like we did for the Flashback Portable.

 

Games I'm working on fixing are SuperCharger Space Invaders and Defender III, not sure why these games come up scrambled; they also do this occasionally on the community build of the Retron77 but not under Hyperkin's default configuration.

 

These are CBS RAM games which have no problem in Stella 4.x or on the Flashback Portable. Anyone know what version of the emu is running on the FB9? One clue is that Kool-Aid man also needs to be patched.

 

  • Like 2

Share this post


Link to post
Share on other sites

post-30777-0-20100600-1543717137.jpg

Here is a patched version of Defender III Trainer Edition that will run on the Atari Flashback 9 HDMI console and all other Atari consoles too:

 

Defender_III_Trainer_v1Hotfix.bin

 

The hotfix version will no longer intermintently crash on the Retron77 consoles community build either (original only works consistently with Hyperkin's firmware).

 

More details on the fix along with a patched SuperCharger Space Invaders ROM and a few other incompatible ROM's patched to follow soon :)

 

Busy working on a SuperCharger game ...

 

Share this post


Link to post
Share on other sites

UPDATE

 

I have a few more patched ROM's to post but if other ROM's are found not to work on the FB9 for this same reason, it is due to a bug in the emu where the decimal flag on the virtual CPU is getting set 100% of the time

 

(and on the Retron77 where the flag is clear initially and the games run, but then gets set frequently on subsequent loads that do not power off and crashes).

 

This error has been corrected in later releases of Stella (the Atari emulator used on the Atari Flashback9 and Retron77 consoles) and there is an initiative underway to resolve similar incompatibilities where initialization is required for broadest compatibility with the real hardware:

 

http://atariage.com/forums/topic/285759-stella-getting-into-details-help-wanted/page-1?do=findComment&comment=4173849

 

Share this post


Link to post
Share on other sites

Sorry, complete newbie here...just got my FlashBack 9 and wondering how I can get Pitfall II working on it. I downloaded what I thought was a 'stella' compatible ROM but it just brings up lines...if you can point me in the right direction to get it working or provide any info that would be most appreciated :)

Share this post


Link to post
Share on other sites

Sorry, complete newbie here...just got my FlashBack 9 and wondering how I can get Pitfall II working on it. I downloaded what I thought was a 'stella' compatible ROM but it just brings up lines...if you can point me in the right direction to get it working or provide any info that would be most appreciated :)

 

Do you have the composite version of the Flashback9? That one uses the AtGames emulator and cannot play Pitfall II. If you have the HDMI version you should be able to play it. Both versions of the Flashback 9 are pretty good but need different hacks for the incompatible ROMs.

Share this post


Link to post
Share on other sites

 

Do you have the composite version of the Flashback9? That one uses the AtGames emulator and cannot play Pitfall II. If you have the HDMI version you should be able to play it. Both versions of the Flashback 9 are pretty good but need different hacks for the incompatible ROMs.

Thanks Mr SQL - yes I have the composite...now I understand why it won't run Pitfall II (my version isn't running the Stella emulator)...appreciate you clearing that up :)

Share this post


Link to post
Share on other sites

Hi, another newbie here, just got my Flashback 9 (HDMI output). Just installed the newest firmware from the AFZ player portal. It said install complete, Now I guess I'm ready to install some new games. Just so I am clear, are Hotfix.ben are they complete games or do I need to load the game first, then the hotfix to make the game work? Also can someone give me a link to games like Pack Man? Thank You very much!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...