Jump to content
Sign in to follow this  
Eltigro

Channel Select Switch going bad?

Recommended Posts

So the other day I was playing some Blackjack, and suddenly lost picture. I ended up "fixing" it by changing the TV channel from 3 to 4. It was as if the channel select switch on the bottom of the controller had been moved even though I hadn't even picked up the console. I looked underneath and manually moved it back and forth from one to the other and it seemed to work fine, so I left it on 4 and continued playing. Then a little while later, it happened again. Had to switch the TV back to 3.

 

Just wondering if someone else has come across this. Is it something common? Any ideas? Do I need a new switch or just to clean this one? Or do I need to have an exorcism?

 

In case it matters, this is on my Super Pro System.

Share this post


Link to post
Share on other sites

The switch is external to the RF modulator. I believe it defaults to channel 4 unless the selector pin is grounded i.e. switched on. If you can get the metal enclosure off you can look to see if something is loose around there. If you disconnect the switch, I think it will stay on channel 4. If it's still not stable than the problem might be inside the rf modulator. Try cleaning the switch first.

Edited by mr_me

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...