Jump to content
Al_Nafuur

PlusCart (an inexpensive DIY WiFi multicart)

Recommended Posts

1 hour ago, alex_79 said:

Ok, now print the logo with a translucent filament, put an RGB led inside wired to 3 unused GPIO pins and make it software programmable.:twisted:

The STM32F4 breakout board has one (or even two) user programmable LED(s) onboard !
But the board is on the other side 😞

 

 

Edited by Al_Nafuur
one is the power LED
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Andrew Davie said:

Yep.

I thought that the logo should face to the TV side... 🤔

Share this post


Link to post
Share on other sites
Just now, vitoco said:

I thought that the logo should face to the TV side... 🤔

Not with @Andrew Davie's design. He made the (cool) logo facing to you.

Share this post


Link to post
Share on other sites
28 minutes ago, Al_Nafuur said:

Not with @Andrew Davie's design. He made the (cool) logo facing to you.

Technically, you can put the logo on either side. Or both. The customiser lets you choose.

But it made sense to me to have the logo facing you.

Share this post


Link to post
Share on other sites
2 hours ago, Andrew Davie said:

Well, the first proto worked just fine and it's gorgeous.

 

 

 

Looks like I have a bit of room on the tolerance, that I can reduce, but basically easy-as.

This will make getting these printed 10x easier and much much cheaper. And super-easy to assemble.

Look at that beautiful texture on the last frame of the video, above!

 

IMG20210312002733.thumb.jpg.ba8d89fe94958c5b06b2d2627266d762.jpg

:-o The texture looks great👍

Share this post


Link to post
Share on other sites
4 minutes ago, Andrew Davie said:

Technically, you can put the logo on either side. Or both. The customiser lets you choose.

But it made sense to me to have the logo facing you.

It seems somehow confusing that way. On every other 2600 cartridge I have, the label goes to the TV side.

 

Then, you have to pay attention to the end label with the name.

 

Share this post


Link to post
Share on other sites
8 minutes ago, vitoco said:

It seems somehow confusing that way. On every other 2600 cartridge I have, the label goes to the TV side.

 

Then, you have to pay attention to the end label with the name.

 

Print it whichever way works for you. The label/wording at top is also flippable.

I have it so I can read "PlusCart" when looking at it.

Share this post


Link to post
Share on other sites

I love the PlusCart, it's great!

 

A minor issue I have with either a RetroTINK 2X-MINI (composite/S-Video version of Pro) and RetroTINK-2X Multi (different tech) HDMI upscaler with my PlusCart in an Atari 7800 upgraded with UAV: screen blanking.

 

In between screens, including the PlusCart text entry, the screen resyncs and blanks out the screen for a moment. Something about the video signal in that special text mode causes the RetroTINK upscalers to act like the video is being turned off and on in every screen, including the spinning plus. I have the usual Atari 2600 upscaled video issues that others have on a handful of games that play with dynamic scan lines or shake the screen, as noted in this thread.

 

Does that just come with the territory with this special text video mode, or is there a chance this could be addressed in a future revision?

Share this post


Link to post
Share on other sites

I added the insert as suggested, and printed a glow-in-the-dark version. As you can see from the video, it was a big success.  Also shows how long the glow lasts after held close to a bright light (the ceiling light just before I started filming, for about 10 seconds).

 

 

 

  • Like 8

Share this post


Link to post
Share on other sites
7 hours ago, Andrew Davie said:

Well, the first proto worked just fine and it's gorgeous.

I expanded that to full screen to better soak it all in.  looks great!

Share this post


Link to post
Share on other sites

Doesn't glow in the dark material glow in UV light?  I know UV light will charge glow in the dark material.

 

Can you add a UV LED to the board right behind the logo?

Share this post


Link to post
Share on other sites

You just have to laugh; what else can you do. I thought since the new design was a major improvement aesthetically, it would be nice to print @Gemintronic's prize cartridge in this design. So, knowing I'm critically short of the glow-in-the-dark filament, I figured I just had enough to print a new front shell. Since I'm particular about these things, I decided to print it super-slow, because the print comes out slightly better quality that way. So, I started it off and 7 and a half hours later it's finished!  Pull it carefully off the bed and turn it over to see how it looks. And there's a hair... embedded in the plastic. Fan-fucking-tastic! Not.  Oh well, time to order another roll, I think. Printing one now though to see if there's enough filament left (I doubt it) for a print. Never had a hair in my print before; go figure.

 

  • Like 1
  • Haha 4
  • Sad 1

Share this post


Link to post
Share on other sites
42 minutes ago, Andrew Davie said:

You just have to laugh; what else can you do. I thought since the new design was a major improvement aesthetically, it would be nice to print @Gemintronic's prize cartridge in this design. So, knowing I'm critically short of the glow-in-the-dark filament, I figured I just had enough to print a new front shell. Since I'm particular about these things, I decided to print it super-slow, because the print comes out slightly better quality that way. So, I started it off and 7 and a half hours later it's finished!  Pull it carefully off the bed and turn it over to see how it looks. And there's a hair... embedded in the plastic. Fan-fucking-tastic! Not.  Oh well, time to order another roll, I think. Printing one now though to see if there's enough filament left (I doubt it) for a print. Never had a hair in my print before; go figure.

 

Just another proof of Murphy's law..

 

  • Like 2

Share this post


Link to post
Share on other sites

Got another one printed. There was enough filament, but barely. It was a close call!

Good thing is I don't need to order another roll to get this out the door :)

 

IMG20210313014139.thumb.jpg.8a5c8d0efda49dd54e43fedf49db7a2f.jpg

 

 

  • Like 2

Share this post


Link to post
Share on other sites
On 3/10/2021 at 5:22 PM, Andrew Davie said:

.. So think "expensive"...

 

 

Printing the pins (approximately the same size as the logo) at craftcloud.com would cost € 1.75

printing them with "Fluorescent Green" would cost just some additional:

grafik.png.8f3ad6c58c369587aedfe3aeb253dfab.png

 

 

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, Al_Nafuur said:

 

Printing the pins (approximately the same size as the logo) at craftcloud.com would cost € 1.75

printing them with "Fluorescent Green" would cost just some additional:

grafik.png.8f3ad6c58c369587aedfe3aeb253dfab.png

 

 

EUR1.75 each set?  If so, ouch!

 

Share this post


Link to post
Share on other sites

I appreciate the time and labor put into the PlusCarts.

 

I've made a small run of 2600 games using 3D printing before.  It's never quite a perfected science.  You could be into the 12th print and half-way through there's a tray full of plastic spaghetti moving around :)

Share this post


Link to post
Share on other sites

On the PlusStore via browser I have dark mode on it seems, any way to change back to white background?

Sent from my SM-N960U using Tapatalk

Share this post


Link to post
Share on other sites
5 minutes ago, Prizrak said:

On the PlusStore via browser I have dark mode on it seems, any way to change back to white background?

Sent from my SM-N960U using Tapatalk
 

click on your user icon on the top right and select "settings" in the dropdown menu. On the left side there should be a menu entry "Accessibility", that's where you can switch the theme.

 

Share this post


Link to post
Share on other sites

Hi guys. I have my Pluscart mounted and ready for first set-up. I want to connect with my PC to the router menu of the Pluscart as per the instructions. From the Wifi Menu I select "Configure Wifi Portal" then I can see the pluscart wifi SSID showing on my PC. Connect to it but then when I want to open the 192.168.4.1 nothing happens and cannot get to the router menu. Have tried multiple different browser and tried both from Windows 10 and Mac OSX but nothing the menu won't open.

What should I do?

Share this post


Link to post
Share on other sites
30 minutes ago, repetto74 said:

Hi guys. I have my Pluscart mounted and ready for first set-up. I want to connect with my PC to the router menu of the Pluscart as per the instructions. From the Wifi Menu I select "Configure Wifi Portal" then I can see the pluscart wifi SSID showing on my PC. Connect to it but then when I want to open the 192.168.4.1 nothing happens and cannot get to the router menu. Have tried multiple different browser and tried both from Windows 10 and Mac OSX but nothing the menu won't open.

What should I do?

You might need to specify the protocol for some Browser. So you need to type:

http://192.168.4.1

 

into the address line of the browser not the google search input field:

grafik.thumb.png.fa01bd73c557a8a95db672893b1947da.png

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...