Jump to content
Bmack36

CollectorVision Phoenix Release Thread

Recommended Posts

7 minutes ago, retroillucid said:

I was told it would be fixed in a later firmware update  (as other known issues) 

Along with Ikrananka's suggestion of including a changelog with the cores, could we get a known issues list of things that are being worked on? Could deflect some error reports of things already being worked on. An organized list of planned new features would be nice too, instead of being spread out over multiple posts in a thread. 

Share this post


Link to post
Share on other sites
Just now, nick3092 said:

Along with Ikrananka's suggestion of including a changelog with the cores, could we get a known issues list of things that are being worked on? Could deflect some error reports of things already being worked on. An organized list of planned new features would be nice too, instead of being spread out over multiple posts in a thread. 

Yes, I guess that's something Bmack36 could include

Also, we'll soon have the Phoenix website up and we'll have all informations there 

  • Like 2

Share this post


Link to post
Share on other sites
15 minutes ago, AtariLeaf said:

Did you try your other tv yet?

Not yet. Just got home and now working on supper. Probably won’t get a chance until the kids go to bed

Share this post


Link to post
Share on other sites

One issue I've not seem mentioned is that the F18A implementation on the Phoenix is set to 32 sprites.  So, sprite masking doesn't work in games like Antarctic Adventure.  When Penta the penguin falls in a hole his entire body is still visible.

 

Are there plans to add a setting for the F18A implementation to allow the user to switch between 4 and 32 sprites, i.e. the F18A USR1 jumper setting?

 

 

Share this post


Link to post
Share on other sites

Might be a long shot, but for those of you with symptoms of the power backfeed, try turning HDMI CEC off on your tv. Some manufacturers have their own name for it, like I think Samsung calls it Anynet or something like that.

Share this post


Link to post
Share on other sites
2 hours ago, Ikrananka said:

One issue I've not seem mentioned is that the F18A implementation on the Phoenix is set to 32 sprites.  So, sprite masking doesn't work in games like Antarctic Adventure.  When Penta the penguin falls in a hole his entire body is still visible.

 

Are there plans to add a setting for the F18A implementation to allow the user to switch between 4 and 32 sprites, i.e. the F18A USR1 jumper setting?

 

 

I think they’ve just been saying you turn the F18A off for Antarctic Adventure, as it is trivial to do with the Phoenix. 

Share this post


Link to post
Share on other sites
21 minutes ago, Swami said:

I think they’ve just been saying you turn the F18A off for Antarctic Adventure, as it is trivial to do with the Phoenix. 

How do you turn off the F18A on the Phoenix?

2 hours ago, nick3092 said:

Might be a long shot, but for those of you with symptoms of the power backfeed, try turning HDMI CEC off on your tv. Some manufacturers have their own name for it, like I think Samsung calls it Anynet or something like that.

I double checked and it was turned off on the tv I tested that was having sound issues and the occasional white screen.

Share this post


Link to post
Share on other sites
51 minutes ago, zaphro72 said:

I am having trouble on the 2600 core starting Yars Revenge and crackpots. It just seems to be cycling through the game options

Try these - they are flashback portable ones with bankswitching simplified. They work on my Phoenix.

Yar_Rev.bin Crackpot.bin

Share this post


Link to post
Share on other sites
2 hours ago, zaphro72 said:

How do you turn off the F18A on the Phoenix?

Bmack said to press * or # in the sd loader menu. # turns off sprite flicker with a flashing message in the bottom right, * turns off scan lines. I'm not sure the whole F18A is disabled.

Share this post


Link to post
Share on other sites
2 hours ago, zaphro72 said:

I am having trouble on the 2600 core starting Yars Revenge and crackpots. It just seems to be cycling through the game options

Actually, here's the whole mess of bank-switch fixed roms for sd card loading. Paddle and keypad conversions are in there as well, but I can't vouch for the conversions and have no idea how the keypad entries were converted.

Phoenix 2600 conversions.zip

  • Like 1

Share this post


Link to post
Share on other sites

I can get most atari games to work now it seems if I just immediately go to start game after loading. If I touch any options I am screwed.

Share this post


Link to post
Share on other sites
8 hours ago, zaphro72 said:

Tried it on my Samsung TV and it doesn't have the same sound issues as the downstairs TV

Good to know. It would nice to figure out what exactly it is about this tv then. If I do get a small used HDMI tv for my game room, it would nice to know what to look for. I can't be bringing my Phoenix with me everywhere I go

Share this post


Link to post
Share on other sites
On 11/2/2019 at 12:34 AM, zaphro72 said:

Got machine gun sound like in AtariLeaf’s video in other thread. Tried different HDMI so it isn’t the cable. Will have to try another tv but hopefully it can work on that tv

 

 

 

I got the same problem,  i bought a hdmi switch to do on off (like à reset) when i switch a cartrige and now work very fine, contact them if you  have problem, they gave me an excellent customer service and we fix the problem in the same day

Share this post


Link to post
Share on other sites
24 minutes ago, Antoine said:

I got the same problem,  i bought a hdmi switch to do on off (like à reset) when i switch a cartrige and now work very fine, contact them if you  have problem, they gave me an excellent customer service and we fix the problem in the same day

Mine is more of a hardware problem since the cartridges don't work at all. White screen every time. We will work on an exchange this week.  

Share this post


Link to post
Share on other sites
10 hours ago, Swami said:

Bmack said to press * or # in the sd loader menu. # turns off sprite flicker with a flashing message in the bottom right, * turns off scan lines. I'm not sure the whole F18A is disabled.

BUT, this ONLY works if playing games from the internal SD card reader and at the SD loader menu.

 

Playing games from cartridge (including the AtariMax carts) bypasses the SD loader menu and the * and # keys then only perform their functions for the game/cart that's inserted and do not affect the Phoenix F18A settings.

 

Also, when turning off the Phoenix the F18A settings always revert to the Phoenix defaults of 32 sprites ("sprite flicker off") and scan lines off.  So, it is not possible to go to the SD loader menu, turn on sprite flicker, power down the Phoenix, insert a cart such as Antarctic Adventure and turn on the Phoenix and have sprite masking working.

 

I really think there needs to be a fix for this.

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Ikrananka said:

BUT, this ONLY works if playing games from the internal SD card reader and at the SD loader menu.

 

Playing games from cartridge (including the AtariMax carts) bypasses the SD loader menu and the * and # keys then only perform their functions for the game/cart that's inserted and do not affect the Phoenix F18A settings.

 

Also, when turning off the Phoenix the F18A settings always revert to the Phoenix defaults of 32 sprites ("sprite flicker off") and scan lines off.  So, it is not possible to go to the SD loader menu, turn on sprite flicker, power down the Phoenix, insert a cart such as Antarctic Adventure and turn on the Phoenix and have sprite masking working.

 

I really think there needs to be a fix for this.

How many games in addition to Antarctic Adventure utilize sprite masking?

Share this post


Link to post
Share on other sites
2 hours ago, Antoine said:

I got the same problem,  i bought a hdmi switch to do on off (like à reset) when i switch a cartrige and now work very fine, contact them if you  have problem, they gave me an excellent customer service and we fix the problem in the same day

Unfortunately the HDMI switch does nothing for the issue I had or at least not the switch that I have. I changed tv's and everything works fine. Hopefully something can be pinpointed as I would rather have it setup on the other tv but it isn't the end of the world.

Share this post


Link to post
Share on other sites
22 minutes ago, zaphro72 said:

Unfortunately the HDMI switch does nothing for the issue I had or at least not the switch that I have. I changed tv's and everything works fine. Hopefully something can be pinpointed as I would rather have it setup on the other tv but it isn't the end of the world.

Yes unfortunately there's probably no one size fits all solution and going out and buying various hardware to hopefully fix the problem is not ideal, especially if what works for one person might not work for another

Edited by AtariLeaf

Share this post


Link to post
Share on other sites

Whew - came home yesterday to my Phoenix!  It's been unopened for 20 hours, though!  :(  Going to check it out in a little while.  I still want to get another one or two in the next round (an Adam one would be cool), but glad i didn't order multiples now.  I'm space challenged and the lack of any packaging makes it a little tough to store easily.  Anybody else get multiples have a good way to tuck away ones you're not currently using?

 

-J

Share this post


Link to post
Share on other sites
7 minutes ago, Oldschool80skid said:

It fits perfectly in one of these available at Dollar General. 

 

Screenshot_20191103-125312_Chrome.jpg

Sweet.  I'll be doing something similar for my Doubledown controllers!  

Share this post


Link to post
Share on other sites

I would like to do some testing of PS/2 keyboards with my Phoenix and so was wondering what keyboard keys/functions can be tested with the Phoenix and the cores in their current form?

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   1 member

×
×
  • Create New...