Jump to content

Recommended Posts

Probably about time for a MENU  / BOOT / 9640 MENU development topic.

 

"9640 MENU" 80 column  [17 Feb 2020]  9640menu 17Feb2020.zip

- Added TIPI clock support.  Menu checks time about every second.  I suppose I could remove the seconds and check ever 30 seconds or so.  I don't know of a way to access the TIPI DSR without blinking the light ;)
- All other clocks are currently untested and might not function.  I can barely understand the spaghetti code I wrote in 2015 (for reasons historically documented). Intent is to rework Classic99 and Triple Tech to use the DSR. MBP/Clulow/Geneve clocks will remain direct-access. .

- Catalog routine overhauled. Sector IO out; level 3 catalog in place.  Allows entry of a path e.g., TIPI.FOLDER1.  or SCS1.FOLDER2. 

- Drill down into  subdirectories and select the file you want to run or view
- FCTN-8 to enter a new path;  use the "..\" to go up a level.  When you are at the root, pressing enter on the "..\" will recatalog the device.

- If you exit the catalog and return the last path is remembered

- The options creation (F4) and the Edit/Save (F5) options are still tied to disk numbers.  Will look to change that down the road.

- The options files are currently compatible with the prior release.  This could change if I enhance the program with paths and other information, or redo the antiquated menu structure.

- If you have a Remind-Me file in the TIPI root in the format MM-YYYY, pressing "Y" at the menu will display the day's reminders and any scratchpad notes.  This feature is a novelty at present and subject to update or removal. The various clock support complexities may dictate my next steps.

- Are there bugs?  Probably. I am using this as my daily menu program via the Horizon 4000B at present.

 

MENU 40 column 7.39 [16 Feb 2020]

- Minor tweak for ROS 8.42c. See ROS development thread. 

 

 

Link to earlier topic related to 9640MENU

 
  • Like 7
  • Thanks 1

Share this post


Link to post
Share on other sites
8 hours ago, InsaneMultitasker said:

- Added TIPI clock support. 

Modernizing the program by adding TIPI clock support was simply brilliant.  I'm betting there way more active users of TIPI's than all the assorted rare/expensive legacy RTC's combined. 

 

8 hours ago, InsaneMultitasker said:

- If you have a Remind-Me file in the TIPI root in the format MM-YYYY, pressing "Y" at the menu will display the day's reminders and any scratchpad notes.  This feature is a novelty at present and subject to update or removal.

  Reveal hidden contents

I'd miss this feature if removed.  It takes like 10 seconds to get used to using.  I keep my calendar on my TI for two reasons; 

One, it gives me an excuse/reason to turn on my TI daily.

Two, I don't like modern calendars on cellphones and or Google that can hoover your private data for who knows what.

 

Also, now with PI.PIO I can also print out my calendar info.

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, --- Ω --- said:

I'd miss this feature if removed.  It takes like 10 seconds to get used to using.  I keep my calendar on my TI for two reasons; 

One, it gives me an excuse/reason to turn on my TI daily.

Two, I don't like modern calendars on cellphones and or Google that can hoover your private data for who knows what.

 

I don't particularly care for the format of the file or how the program manipulates it -- but I am not interested in rewriting remindme ;)  What I might do is break out the reminder display into a separate small program that can be launched from the menu or any other EA5 loader however until it impedes other work it will stay inside menu.  (I used to use REMINDME on the Geneve, so there is a bit of nostalgia too)

  • Like 1

Share this post


Link to post
Share on other sites

catalog doesn't seem to load subdirs 

I mapped DSK4. to .  and then arrow down to a subdirectory and hit enter, comes up with only .. and that's it though there's plenty of files/directories in that directory

Share this post


Link to post
Share on other sites

My DSK3 is mapped to "." and it drills into subdirectories.  Does it work if you specify "TIPI."?   If the volume is blank (in older versions) it halts immediately but the version I uploaded should be fine.  I'll test it tonight to be sure.

1 hour ago, arcadeshopper said:

catalog doesn't seem to load subdirs 

I mapped DSK4. to .  and then arrow down to a subdirectory and hit enter, comes up with only .. and that's it though there's plenty of files/directories in that directory

 

Share this post


Link to post
Share on other sites
My DSK3 is mapped to "." and it drills into subdirectories.  Does it work if you specify "TIPI."?   If the volume is blank (in older versions) it halts immediately but the version I uploaded should be fine.  I'll test it tonight to be sure.
 
Ok I'll see if the one I'm running is different than the post

Sent from my LM-G820 using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

Atrax uncovered a problem with the 40 column menu.  After you edit the menu options and attempt to save the file back to the ramdisk, the save routine masks the drive unit number to 1-9.  If you use a drive letter (e.g., A-Z) for your ramdisks the save fails.  I'll patch the MENU739c program when I have time and in the interim:

 

Search for first occurrence of hex string  >D060 400F 0241 0F00  and change to >D060 400F 1000 1000.

 

The offending code copies the drive unit number from the ROS memory space (>400F) and masks it before being moved into the DSR PAB.  The >1000 >1000 overwrites the instruction with NOP.

 

BF     MOVB @>400F,R1    Got CRU        >D060,>400F        '.`@.'         292E
       ANDI R1,>0F00     drive# (1-9 only?)
       AI   R1,>3000                    >0221,>3000        '.!0.'         2936
       MOVB R1,@BG       DN()           >D801,>3548        '..5H'         293A
       MOVB @>4017,R1    color          >D060,>4017        '.`@.'         293E
       MOVB R1,@VDPREG   patch vregs 7  >D801,>3CC2        '..<.'         2942
       MOVB R1,@BASREG   "  "           >D801,>3B12        '..;.'         2946

  • Like 4

Share this post


Link to post
Share on other sites

we had a totally rewritten more graphical menu system for ros9, called RAMOS Directory -- my plan is to dust it off and release it, i wanted to long time ago, and I gave out a test copy to couple of people, but for some reason it does not function anymore on real iron ti99 equipment, all tho it still works perfectly for me on my classic99 and v9t9 setups, which is all i had to use for a while, as my original ti99 real iron equipment is back in storage in canada, and my local equipment got half stolen and half destoried by hurranice matthew, but thanks to few kind souls and some hard earn cash, i been slowly rebuilding equipment off ebay and shipping it down here to DR which is killer, just empty peb is 500 in shipping plus another 200 in taxes, and once its all arrived and hooked up, and my 4000b is propulated with ram, i going to figure out why RAMOS no longer works on real iron and get that out in wild for people to use and suggest improvements on.

  • Like 4

Share this post


Link to post
Share on other sites

Is RAMOS a catalog program?  Sounds familiar. Did you show it at Lima back in the 90s?  Would be nice to see a few screenshots, even if they are emulated.  A lot of us use emulation for things these days :)

 

  • Like 2

Share this post


Link to post
Share on other sites

so if i "chain" boot programs.. ie load boot from boot, the xb program load portion stops working.. is this a feature or a bug?  it just drops me at a ready prompt after loading the program just like if i typed new

 

Greg

Share this post


Link to post
Share on other sites
2 minutes ago, arcadeshopper said:

so if i "chain" boot programs.. ie load boot from boot, the xb program load portion stops working.. is this a feature or a bug?  it just drops me at a ready prompt after loading the program just like if i typed new

 

Greg

I would first ask why are you loading BOOT from BOOT? 

 

On my system I periodically load the latest version of boot from boot for testing.  I've never tried an XB program load in this situation.  Are you using a standard XB cart or some variant?  If the latter, which one?

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, InsaneMultitasker said:

I would first ask why are you loading BOOT from BOOT? 

 

On my system I periodically load the latest version of boot from boot for testing.  I've never tried an XB program load in this situation.  Are you using a standard XB cart or some variant?  If the latter, which one?

why ask why

 

actually i wanted a "games" menu so i figured, why not make another boot that is just games.. and load that..then i have that load the games directly..or even another boot that has say infocom games ;)

 

Standard XB.. 32k/tipi sidecar, usb keyboard stock console otherwise

Share this post


Link to post
Share on other sites

Oh ok.  So we are talking the 40 column boot right? Attach a copy here and I'll look tonight.

 

(The 80 column menu lets you save and load the chained options (menus) so that's why I was not tracking)

 

Share this post


Link to post
Share on other sites
50 minutes ago, InsaneMultitasker said:

Oh ok.  So we are talking the 40 column boot right? Attach a copy here and I'll look tonight.

 

(The 80 column menu lets you save and load the chained options (menus) so that's why I was not tracking)

 

no this is the 80 column one. maybe im using it wrong? :) 

 

i have option G loading TIPI.GAMES.MENU which then loads has an option A for EA5 GAMES loading TIPI.GAMES.EA5.LOAD  and load doesn't load.. 

 

Share this post


Link to post
Share on other sites
13 hours ago, InsaneMultitasker said:

Is RAMOS a catalog program?  Sounds familiar. Did you show it at Lima back in the 90s?  Would be nice to see a few screenshots, even if they are emulated.  A lot of us use emulation for things these days :)

 

Some info about it is here on my website: --> https://o-p-a.biz/ramos/

 

Sadly, my website is years out of date, last time i updated it was in 2016 for our 30th anniversary since OPA started, and then it got forgotten again, its a real shame as we in the web hosting business and handle over 250 custom websites for people, let we can never get around to updating our own, haha! :)

  • Like 2

Share this post


Link to post
Share on other sites
8 minutes ago, arcadeshopper said:

no this is the 80 column one. maybe im using it wrong? :) 

 

i have option G loading TIPI.GAMES.MENU which then loads has an option A for EA5 GAMES loading TIPI.GAMES.EA5.LOAD  and load doesn't load.. 

 

OK so it is an F18A modified console then.    I'll test your sequence on my system. 

 

The easy way to chain IMHO is to use the Fctn-4 feature to save the options to disk in a separate file. It is hardcoded at the moment; that will change.  The options file is just the information from the menu. So you can load them into memory without loading the full MENU.  I think Atrax is using that feature not sure of anyone else besides me.  I have a few plans to improve upon what is saved in that options.

Share this post


Link to post
Share on other sites
2 minutes ago, InsaneMultitasker said:

OK so it is an F18A modified console then.    I'll this sequence on my system. 

 

The easy way to chain IMHO is to use the Fctn-4 feature to save the options to disk in a separate file. It is hardcoded at the moment; that will change.  The options file is just the information from the menu. So you can load them into memory without loading the full MENU.  I think Atrax is using that feature not sure of anyone else besides me.  I have a few plans to improve upon what is saved in that options.

ahh k.so i could "load" another page of options, that'd be what i am trying to do by just loading another copy of boot

Share this post


Link to post
Share on other sites
7 minutes ago, arcadeshopper said:

ahh k.so i could "load" another page of options, that'd be what i am trying to do by just loading another copy of boot

Yep. I tried your sequence by trying to load DSK1.LOAD from TIPI and it worked. Both using Fctn-7 just to drop into standard XB and as a load/run. 

 

I also tried using TIPI.TERM80.LOAD and that seemed to work. Can you load the file manually, i.e., go into XB and type "OLD TIPI.GAMES.EA5.LOAD"

 

Lunch is over... will look again this evening.

Share this post


Link to post
Share on other sites

[ - get menu

] - put menu

 

I have about 4 menus using this method - works great. 
read the dox. 

Share this post


Link to post
Share on other sites

so you loaded a menu program from the menu program then loaded a load?   it works on the first one but not the 2nd. for me.. 

1 minute ago, sparkdrummer said:

[ - get menu

] - put menu

 

I have about 4 menus using this method - works great. 
read the dox. 

thanks but this doesn't work in 9640menu

 

Share this post


Link to post
Share on other sites
2 minutes ago, InsaneMultitasker said:

Yep. I tried your sequence by trying to load DSK1.LOAD from TIPI and it worked. Both using Fctn-7 just to drop into standard XB and as a load/run. 

 

I also tried using TIPI.TERM80.LOAD and that seemed to work. Can you load the file manually, i.e., go into XB and type "OLD TIPI.GAMES.EA5.LOAD"

 

Lunch is over... will look again this evening.

yep it works fine manually.. it's just when I load another copy of menu from menu then try to load a xb program

Share this post


Link to post
Share on other sites

My system has the 80-col MENU program and the last entry is to load another 80-column menu that I have designated as "BOOT" on another drive. The last entry on that menu reloads the original MENU program. I am running them with XB 2.7 installed and everything works fine. I can load EA or XB programs from either menu and any option. Of course, this is the original "9640" MENU program that the insane one put together previously - not the one in this thread.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...