Jump to content
Sign in to follow this  
gs80065xe

SpartaDosX not reading SpartaDos 3.2 diskette.

Recommended Posts

I have an old diskette with AMP(Antic Music Processor) and some music files. It's formatted with SpartaDos 3.2. I can boot SpartaDos 3.2 diskette. Insert this diskette and view and execute the files. But the same diskette cannot be read when I boot SpartaDosX 4.49 from AVG cart. I get 148 Unknown file system. SpartaDosX can read the SpartaDos 3.2 boot diskette. As well as another diskette I've tried.

Share this post


Link to post
Share on other sites

RTFM. Check your settings. This is NOT difficult.

 

  • Sad 1

Share this post


Link to post
Share on other sites

Sounds like maybe the disk in question has some unexpected data in sector 1, some magic identifier that SDX checks for to determine if the disk is Sparta or AtariDOS is not quite right.

 

You could just copy all the files to a fresh formatted sparta disk, use the "BOOT" command on the particular executable that boots (ie X32D.SYS) if its bootable...

 

Then if you're still interested to find out the underlying reason "why" post an ATR of the disk in question here and maybe someone will figure it out. :)

Share this post


Link to post
Share on other sites

Thanks for the replies. I have searched the manual and Google to help figure this out. But I was unable to find something that fits. Not sure what setting could be an issue. I have all the necessary drivers in my configuration.sys file. I”ll try copying the files to a new diskette. 

Share this post


Link to post
Share on other sites
Posted (edited)

Please copy this unreadable floppy to an ATR and post here. You could also (having made a safety copy before) run the CLX program from the SDX Toolkit, which could probably tell you, what is wrong there.

 

EDIT: the most common cause of this behaviour is that the disk is formatted in the AtariDOS FS format, and the ATARIDOS.SYS driver has not been loaded in SDX.

Edited by drac030
  • Like 2

Share this post


Link to post
Share on other sites
On 8/2/2020 at 4:38 AM, Kyle22 said:

RTFM. Check your settings. This is NOT difficult.

 

Please google the terms "netiquette" and "eternal september" and think about it. Thanks.

  • Like 3

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...