Jump to content
Mr Robot

Fujinet TNFS Server Image

Recommended Posts

39 minutes ago, tschak909 said:

Did you modify the wpa supplicant config in the boot partition, as it says in the doc?

-Thom

I certainly did.

 

and I verified it in the /etc/wpa_supplicant/wpa_supplicant.conf file after.

Edited by tsom

Share this post


Link to post
Share on other sites
49 minutes ago, tsom said:

While I already had my own manually built TNFS server on an RPi, I thought I'd give this a try. It seemed to work just fine, but then I noticed the Wifi was not enabled - it didn't seem to even recognize there was Wifi available. I didn't notice at first, as my Pi is connected with an ethernet cable to my network. When I went to connect to it via ssh, I was getting errors about 'rfkill' not available.

rfkill: cannot open /dev/rfkill: Permission denied
rfkill: cannot read /dev/rfkill: Bad file descriptor

 

I traced it to the Wifi not recognized. Doing the 'iwconfig' command returns:

[email protected]:/etc/network $ iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

[email protected]:/etc/network $ iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

I tried to look up the problem and found command to try to manually start up the wifi, but it didn't work:

 

[email protected]:/boot $ sudo service wpa_supplicant stop
[email protected]:/boot $ ps -A | grep 'wpa'
[email protected]:/boot $ ps -A | grep wpa
[email protected]:/boot $ sudo wpa_supplicant -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf
Successfully initialized wpa_supplicant
nl80211: 'nl80211' generic netlink not found
Failed to initialize driver 'nl80211'

So I gave up and went back to my configured server (but am adding AFP support).

 

 

What model Raspberry pi did you use? 

Share this post


Link to post
Share on other sites
10 minutes ago, Mr Robot said:

What model Raspberry pi did you use? 

3B I believe. I know Wifi works, as using my original setup, I can access it

wlan0     IEEE 802.11  ESSID:"Salem"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 14:22:DB:AE:33:06
          Bit Rate=11 Mb/s   Tx-Power=31 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=70/70  Signal level=-35 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.

lo        no wireless extensions.

 

Share this post


Link to post
Share on other sites

OK I'll write the image to a card and try it here on a 3B... 

 

Share this post


Link to post
Share on other sites
2 hours ago, tsom said:

3B I believe. I know Wifi works, as using my original setup, I can access it

 

Might want to verify if it's a 3B or 3B+ if there's any question as to which one it may be.  The plus models substantially changed the wifi chipset over the 3B as well as a number of other things.
 

FWIW, I have both 3Bs and 3B+es here if any testing needs to be done.

Edited by x=usr(1536)

Share this post


Link to post
Share on other sites

I just tried it on a 3B and a 3B+, also a 2B and a 1 with USB wifi dongles in them and it worked fine in all of them. 

 

I'd try writing the card and setting up the wpa_supplicant.conf again, it's definitely something screwy at your end @tsom!

  • Like 1

Share this post


Link to post
Share on other sites
23 minutes ago, Mr Robot said:

I just tried it on a 3B and a 3B+, also a 2B and a 1 with USB wifi dongles in them and it worked fine in all of them. 

 

I'd try writing the card and setting up the wpa_supplicant.conf again, it's definitely something screwy at your end @tsom!

Ok, I'll give it a try :)

 

Thanks

Share this post


Link to post
Share on other sites
15 hours ago, Mr Robot said:

I just tried it on a 3B and a 3B+, also a 2B and a 1 with USB wifi dongles in them and it worked fine in all of them. 

 

I'd try writing the card and setting up the wpa_supplicant.conf again, it's definitely something screwy at your end @tsom!

Well, I just tried re-imaging and it still does not see any WIFI. I had to use an ethernet cable to even access the Pi.

 

Warning: the ECDSA host key for 'tnfs.local' differs from the key for the IP address '192.168.7.119'
Offending key for IP in /Users/johntsombakos/.ssh/known_hosts:21
Matching host key in /Users/johntsombakos/.ssh/known_hosts:22
Are you sure you want to continue connecting (yes/no)? yes
[email protected]'s password:
Linux tnfs 5.4.83-v7+ #1379 SMP Mon Dec 14 13:08:57 GMT 2020 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
rfkill: cannot open /dev/rfkill: Permission denied
rfkill: cannot read /dev/rfkill: Bad file descriptor
[email protected]:~ $ iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

from cat /proc/cpuinfo:

Hardware	: BCM2835
Revision	: a02082
Serial		: 00000000cec343fd
Model		: Raspberry Pi 3 Model B Rev 1.2

 

Share this post


Link to post
Share on other sites

I've replicated that here on another Pi3... leave it with me.

 

  • Like 2

Share this post


Link to post
Share on other sites
37 minutes ago, Mr Robot said:

I've replicated that here on another Pi3... leave it with me.

 

Works for me. Seems some sort of missing driver issue, as near as I can tell(?)

Share this post


Link to post
Share on other sites

Yeah rfkill isn't running. It's almost like disable_wifi has been set in config.txt it's very odd. I have one pi it happens on. I'm rebuilding the image using that pi, I shall try it on all the others when I'm done and upload a new image to the website if it's ok everywhere.

 

  • Like 1

Share this post


Link to post
Share on other sites

OK I've uploaded a new version of the server image to my website. I built this using the Pi3 that didn't work with the old server image and tested it with a PI1B/2B/3B/3B+/4B/Zero/ZeroW. For the non-Wi-Fi equipped Pi's I used Edimax USB Wi-Fi adapters. I don't have any model A boards or compute modules to test with.

 

Give that a try!

 

Share this post


Link to post
Share on other sites
14 hours ago, Mr Robot said:

OK I've uploaded a new version of the server image to my website. I built this using the Pi3 that didn't work with the old server image and tested it with a PI1B/2B/3B/3B+/4B/Zero/ZeroW. For the non-Wi-Fi equipped Pi's I used Edimax USB Wi-Fi adapters. I don't have any model A boards or compute modules to test with.

 

Give that a try!

 

That did it! Wifi is now working! (Initially I wasn't able to see it or connect to it, so had to use the ethernet cable. Then I realized I was a dumb** and forgot to edit the wpa_supplicant.conf file! Doh! Quick edit and it's all set)

 

Thanks!

  • Like 1

Share this post


Link to post
Share on other sites

Looks like there may be an issue with the Samba service. Looking into it now:

[email protected]:/etc/samba $ sudo systemctl restart smbd
Job for smbd.service failed because the control process exited with error code.
See "systemctl status smbd.service" and "journalctl -xe" for details.
[email protected]:/etc/samba $ systemctl status smbd.service
● smbd.service - Samba SMB Daemon
   Loaded: loaded (/lib/systemd/system/smbd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2021-01-13 06:37:35 CST; 12s ago
     Docs: man:smbd(8)
           man:samba(7)
           man:smb.conf(5)
  Process: 648 ExecStartPre=/usr/share/samba/update-apparmor-samba-profile (code=exited, status=0/SUCCESS)
  Process: 649 ExecStart=/usr/sbin/smbd --foreground --no-process-group $SMBDOPTIONS (code=exited, status=203/EXEC)
 Main PID: 649 (code=exited, status=203/EXEC)

Jan 13 06:37:35 tnfs systemd[1]: Starting Samba SMB Daemon...
Jan 13 06:37:35 tnfs systemd[649]: smbd.service: Failed to execute command: Exec format error
Jan 13 06:37:35 tnfs systemd[649]: smbd.service: Failed at step EXEC spawning /usr/sbin/smbd: Exec format error
Jan 13 06:37:35 tnfs systemd[1]: smbd.service: Main process exited, code=exited, status=203/EXEC
Jan 13 06:37:35 tnfs systemd[1]: smbd.service: Failed with result 'exit-code'.
Jan 13 06:37:35 tnfs systemd[1]: Failed to start Samba SMB Daemon.

There may be bigger issues here:

[email protected]:/etc/samba $ testparm
testparm: error while loading shared libraries: /lib/arm-linux-gnueabihf/libsmbconf.so.0: invalid ELF header

[email protected]:/etc/samba $ sudo apt update
Get:1 http://archive.raspberrypi.org/debian buster InRelease [32.6 kB]
Get:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Get:3 http://archive.raspberrypi.org/debian buster/main armhf Packages [351 kB]
Fetched 399 kB in 2s (192 kB/s)
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/dpkg/status
E: The package lists or status file could not be parsed or opened.

 

Edited by tsom

Share this post


Link to post
Share on other sites
30 minutes ago, Mr Robot said:

hmm do a apt-get update and upgrade

 

I did, that's where I'm getting the error above

[email protected]:~ $ sudo apt-get update
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/dpkg/status
E: The package lists or status file could not be parsed or opened.
[email protected]:~ $

I did try some solutions I found online (replacing the status file with a backup, etc. but it didn't help)

 

I tried to update the time zone via raspi-config and it threw a boatload of errors also (this is just the end of the errors, most scrolled off)

 line 1083.
Use of uninitialized value $value in substitution (s///) at /usr/share/perl5/Debconf/Format/822.pm line 65, <__ANONIO__> line 1084.
Use of uninitialized value $value in substitution (s///) at /usr/share/perl5/Debconf/Format/822.pm line 65, <__ANONIO__> line 1085.
Use of uninitialized value $value in substitution (s///) at /usr/share/perl5/Debconf/Format/822.pm line 65, <__ANONIO__> line 1086.
Use of uninitialized value $value in substitution (s///) at /usr/share/perl5/Debconf/Format/822.pm line 65, <__ANONIO__> line 1087.
Use of uninitialized value $value in substitution (s///) at /usr/share/perl5/Debconf/Format/822.pm line 65, <__ANONIO__> line 1088.
Use of uninitialized value $item in hash element at /usr/share/perl5/Debconf/DbDriver/File.pm line 85, <__ANONIO__> chunk 1088.
dpkg-query: error: parsing file '/var/lib/dpkg/status' near line 0:
 end of file during value of field '_ENSC_18_Mod_range_hashingENSC_20_Default_ranged_hashENSC_20_Prime_rehash_policyENSC_17_Hashtable_traitsILb1ELb0ELb1EEEE19_M_allocate_bucketsEj' (missing final newline)
dpkg-query: error: parsing file '/var/lib/dpkg/status' near line 0:
 end of file during value of field '_ENSC_18_Mod_range_hashingENSC_20_Default_ranged_hashENSC_20_Prime_rehash_policyENSC_17_Hashtable_traitsILb1ELb0ELb1EEEE19_M_allocate_bucketsEj' (missing final newline)
/usr/sbin/dpkg-reconfigure: tzdata is not installed

 

Edited by tsom

Share this post


Link to post
Share on other sites

It looks like the pishrink.sh corrupted a few blocks in the image somehow. I'm getting the same issue here with the shrunk image but not the pre shrink image. 

 

I'll try rebuilding it later.

 

The 16gb µSD I used is throwing read errors, it looks like I wore it out. I've ordered some more, will be here tomorrow.

 

 

Share this post


Link to post
Share on other sites

OK V1.3 of the image is now uploaded, this time there are no block errors and I checked the MD5's of the image after backing it up twice to make sure it was OK. 

 

I've added a command. If you type 'sudo tnfsupd' at a command prompt it will grab the latest code from github, compile it and replace the existing TNFSD daemon with the new version. 

 

  • Like 1

Share this post


Link to post
Share on other sites

OK. NOT trying to start a flame war. The version of Windows is irrelevant here. SelfImage works perfectly w/ XP32. But.

The problem is the Pi boots the image fine. I can log in at the console. There is no wlan0 device. I believe this a Pi3 device.

 

I am looking for a link to the image of TNFS server for Pi3.

 

Thanks.

 

Share this post


Link to post
Share on other sites

If you downloaded the image before my last post, download it again.

 

The SD card I was using to build the server was nearly end of life and started giving bad blocks. I got some new cards and built a new image today which I've tested on a Pi3 and a PiZeroW

 

  • Like 1

Share this post


Link to post
Share on other sites

What USB WiFi dongle are you using? I tested with an Edimax one. 

 

Share this post


Link to post
Share on other sites
16 hours ago, Mr Robot said:

If you downloaded the image before my last post, download it again.

 

The SD card I was using to build the server was nearly end of life and started giving bad blocks. I got some new cards and built a new image today which I've tested on a Pi3 and a PiZeroW

 

Will give this a try this afternoon and report back. 

Share this post


Link to post
Share on other sites
On 1/15/2021 at 4:16 PM, Mr Robot said:

OK V1.3 of the image is now uploaded, this time there are no block errors and I checked the MD5's of the image after backing it up twice to make sure it was OK. 

 

I've added a command. If you type 'sudo tnfsupd' at a command prompt it will grab the latest code from github, compile it and replace the existing TNFSD daemon with the new version. 

 

I installed this version and noticed that the wpa_supplicant.conf file was not at the root of the image on the SD card. I booted the Pi and had to use the ethernet card to connect to it. I edited the /etc/wpa_supplicant/wpa_supplicant.conf file and rebooted, but that didn't seem to work, but when I used raspi-config to set the SSID and password, that got everything working. So far anyway :) apt-get update works now too.

 

Thanks!

Share this post


Link to post
Share on other sites

Gah I forgot to reset the wifi settings! OK another version is uploading now, should be there in about 20 mins.

 

EDIT: It's there now

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...