Jump to content
Charles Darwin

Multi Boot Loader for USB/eMMC

Recommended Posts

Posted (edited)
On 6/12/2021 at 4:33 PM, 0_obeWAN said:

I usually do it the other way around.
- I install Windows on USB and I duplicate on the internal M.2 card, which erases it completely.
- I reduce the Windows partition and create my other partitions to the desired size.
- In each of the partitions I restore a system that I have previously backed up with DiskGenius in .pmf format that restore filesystem to

So if I were you, I would backup the Batocera and Ubuntu partitions. And I would transfer Windows to M.2 internal + restore the backups

 

Ok, I now have Windows and Batocera installed on the M.2 and working great.  For the life of me though, I can't figure out how to get Ubuntu to install entirely on the M.2 card.  When installing, I created a 512MB EFI system partition on /dev/sda6 and told the installer to place the boot loader (grub) on that partition - but for some reason it installs the boot loader on the system partition.  Any idea on how to get around this?  Sorry for the poor picture quality, my phone hates taking pictures of the TV.

If I re-flash the Atari - the bootloader for Ubuntu goes away... which is not exactly desirable.

 

IMG_6437.jpg

IMG_5535.JPG

Edited by moonchilddave

Share this post


Link to post
Share on other sites
23 hours ago, moonchilddave said:

Ok, I now have Windows and Batocera installed on the M.2 and working great. 

Hello,

At this point my method

In Windows disk manageur I reduce Windows primary partition with size you want for Ubuntu

I create a new partition, don' t have to format

In Ubuntu find your partiton, create, format EXT4 with "\" for partition

For Grub, sorry I forget  the name of partition in Linux but this is the first EFI partition on eMMC (This partition serves no other purpose than Grub, not for Apertis)

 

With rEFInd VCS or Grub VCS Multi boot loader you can delete Grub for Ubuntu BUT You don't see Atari logo during start, only texte

To keep logo indicate to rEFInd VCS or Grub VCS to point bootx64.efi

Share this post


Link to post
Share on other sites
23 hours ago, moonchilddave said:

 

If I re-flash the Atari - the bootloader for Ubuntu goes away... which is not exactly desirable.


IMG_5535.JPG

No :( Because your Grub is on first partition on eMMC is efi(0) on picture

Restauration disk don't format this first partition I believe, verify but I think it doesn't format it

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, 0_obeWAN said:

No :( Because your Grub is on first partition on eMMC is efi(0) on picture

Restauration disk don't format this first partition I believe, verify but I think it doesn't format it

I can confirm that if you use the flasher provided by Atari here: https://docs.google.com/document/d/17TeJMIZcLIsGMJEHlQAxOb_YdIuX4GoL4bvBExAudWU/ it does indeed erase the Ubuntu/grub boot loader installed on efi(0).  I'm thinking that what I want to do is back that partition up and restore it to the M.2 drive.  Just wanted others who may be reading to be aware of this catch, as it might save them some time and frustration. 

So I copied the contents of efi(0) to the EFI partition I created on M.2 drive and it now works as expected... without losing the Atari logo on boot.

Edited by moonchilddave
  • Like 1

Share this post


Link to post
Share on other sites

So now I'm running into an issue with using Disk Genius to copy the rEFInd files to the efi(1) & efi(2) partitions.

 

Do you need the paid version to copy?  I tried dragging the EFI folder to both partitions but nothing happens.  The partitions look like they are locked or something.

Share this post


Link to post
Share on other sites
12 minutes ago, moonchilddave said:

So now I'm running into an issue with using Disk Genius to copy the rEFInd files to the efi(1) & efi(2) partitions.

 

Do you need the paid version to copy?  I tried dragging the EFI folder to both partitions but nothing happens.  The partitions look like they are locked or something.

Does you eMMC isn't read only or offline ? It works with free version I just try

 

 

image.thumb.png.19d27c26585a3d568ab6e8d677e148eb.png

 

image.thumb.png.ee72183ee6987e97c1f84e4ca7f58b86.png

 

image.thumb.png.17efb0323b8402d829e97b4cf54bb3b1.png

 

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
13 minutes ago, 0_obeWAN said:

Does you eMMC isn't read only or offline ? It works with free version I just try

 

 

image.thumb.png.19d27c26585a3d568ab6e8d677e148eb.png

 

image.thumb.png.ee72183ee6987e97c1f84e4ca7f58b86.png

 

image.thumb.png.17efb0323b8402d829e97b4cf54bb3b1.png

 

 

 

 

It looks locked to me...

414D29CE-947B-4AA6-8ABD-FA3124A24B94.jpeg

Share this post


Link to post
Share on other sites
1 hour ago, moonchilddave said:

Ok, I'm an idiot, missed the part about taking the drive online.  Got it up now, but why so many multiple choices?

0DD4E994-871B-4B73-9885-6F2C3CE7FCA4.jpeg

You have to try one by one choose good ones and mask those you don't need (Supp and confirm only mask)

Eatch one icons point to an .efi file or bootable Linux image 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, 0_obeWAN said:

You have to try one by one choose good ones and mask those you don't need (Supp and confirm only mask)

Eatch one icons point to an .efi file or bootable Linux image 

I found hitting DEL (not Delete) over an icon pops up a dialog to hide it.  Confirm, and all is great!  Thanks for all your help!!!

Edited by moonchilddave
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...