Jump to content

Recommended Posts

11 hours ago, MasterMotorola said:

Mike, yes Motorola made a 50Mhz 68882 FPU.  I was considering getting one until I found out the CaTTamaran overclocks the FPU as well so there would really be no speed boost.

The problem I’m having is my FPU is not stable over clocked.  I have even tried a 40 mhz version, but no luck. I would love to find a 50 mhz version to fix this problem. Otherwise I will have to make a small mod and run my FPU at 32 mhz. 

Share this post


Link to post
Share on other sites

Right with ya. I've got a 40mhz 68882 in my Pak 68/3 equipped STacy and in

some of the benchmarking threads in other forums I was requested to run

Nembench because of some odd results I got.

 

Can't. It fails, so it seems I have a faulty 68882.  :(

 

(even though Gembench, and all the other software runs fine with no crashes. This

includes software that uses an FPU. Go figure)

 

Share this post


Link to post
Share on other sites
21 hours ago, DarkLord said:

Can't. It fails, so it seems I have a faulty 68882.  :(

More than likely it is not faulty, we are just trying to make it do something it was never designed to do.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, mdivancic said:

More than likely it is not faulty, we are just trying to make it do something it was never designed to do.

 

Be nice to think that but the testing software they asked me to use (NEMBENCH, by Douglas Little) works

fine on other people's setups, including Pak boards... :(

 

NEMBENCH is not benchmarking software per se - it actually tests the 68882/1, if I my understanding of it is

correct.... (of course, I get things wrong all the time)

 

Share this post


Link to post
Share on other sites
4 hours ago, DarkLord said:

Be nice to think that but the testing software they asked me to use (NEMBENCH, by Douglas Little) works

fine on other people's setups, including Pak boards... :(

 

NEMBENCH is not benchmarking software per se - it actually tests the 68882/1, if I my understanding of it is

correct.... (of course, I get things wrong all the time)

NEMBENCH looks like it’s just a benchmark program from a quick search of the forums. Can you step the speed of your setup down and test? I’m sure it’s a speed issue with the FPU. While there are plenty of people who run there FPU at 48mhz, there are many who can’t. My 33 mhz and 40 mhz FPUs both run for hours at 32 mhz. Neither will run at all at 48mhz. 

Share this post


Link to post
Share on other sites

My bad...I've been running so many bench marking tests lately that I

got NEMBENCH confused with FPUTEST.

 

FPUTEST is the one that fails on my setup. It's supposed to test the

FPU, not benchmark it.

 

Sorry about the confusion.  :(

 

Unfortunately, with the Pak 68/3 boards, you are supposed to run the CPU and FPU at the same speeds.

 

So I'm running the 68030 at 40mhz....you get the picture.

 

With the Pak board, you change the CPU, FPU and oscillators, matching them all up to the same mhz. That's

what's recommended.

 

When/if I take my STacy apart I can play around with different speeds. Taking a STacy apart is not a light

undertaking.   :)

 

Share this post


Link to post
Share on other sites

I have only seen 50MHz in PGA. Max in PLCC I have seen is 40MHz. I don't think 50MHz was made in PLCC package.

Share this post


Link to post
Share on other sites
3 hours ago, snarkdluG said:

I have only seen 50MHz in PGA. Max in PLCC I have seen is 40MHz. I don't think 50MHz was made in PLCC package.

I kinda figured that...

Share this post


Link to post
Share on other sites
3 hours ago, DarkLord said:

When/if I take my STacy apart I can play around with different speeds. Taking a STacy apart is not a light

undertaking.   :)

As I well know...

 

send me FPUTEST please. May as well test mine. 

Share this post


Link to post
Share on other sites
Posted (edited)

Interesting FPU conversation.

Does anyone knows if this will work in my Atari ST/e ( ICD AdSpeed STE 16MHz ).

20210528_205245.thumb.jpg.7f88d86d2c181c971358e0ffa1871222.jpg

 

 

Can't find online manual for ICD AdSpeed STE 😟

Edited by Chri O.

Share this post


Link to post
Share on other sites
3 hours ago, Chri O. said:

Interesting FPU conversation.

Does anyone knows if this will work in my Atari ST/e ( ICD AdSpeed STE 16MHz ).

20210528_205245.thumb.jpg.7f88d86d2c181c971358e0ffa1871222.jpg

 

 

Can't find online manual for ICD AdSpeed STE 😟

Probably yes. The 68882 is asynchronous and can have a different speed then the 68000. The AdSpeed for STe is missing the oscillator so you also need to fit that. So you could probably have 20MHz oscillator in there for the 68882. Or 32MHz or 50MHz if you have faster 68882.

Share this post


Link to post
Share on other sites

Hmm, what are you using to access the 68882?

 

In my case, the Pak board has an option for a 68881/2.

 

This ZIP should contain what you need for the AdSpeed:

 

ADSPEED ST.ZIP

 

 

Share this post


Link to post
Share on other sites
8 hours ago, mdivancic said:

As I well know...

 

send me FPUTEST please. May as well test mine. 

 

Sure, hope yours is fine.   :)

 

fputest.zip

 

 

Share this post


Link to post
Share on other sites

If I haven't asked this before, is there a list of programs for the ST/TT/Falcon that actually supports the 68881/2?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...