Jump to content
rxd

Games That Don't Start In An Emulator

Recommended Posts

Hi,

I was just wondering if there was any patches or anything that I can do about Atari 5200 games that don't start in an emulator. Star Trek and Pitfall imediately come to mind as 2 games that I can't get to start in my 5200 emulator. I was just wondering if there was anything I could do.

 

Thanks

Share this post


Link to post
Share on other sites

I've never gotten Star Trek to work in any emulator. I've tried Atari800Win, Atari800DC for Dreamcast, XPorts Atari 5200 emultor for the Xbox, etc.

Share this post


Link to post
Share on other sites
Star Trek handles the keypad in a funny way that most of the other emulators haven't compensated for.  

 

Dan

 

I noticed StarTrek was reading codes directly from KBCODE and not masking them. I didn't go any further to see why the reads failed. I'm guessing it might have to do with the unused bits.

 

-Bry

Share this post


Link to post
Share on other sites

I noticed StarTrek was reading codes directly from KBCODE and not masking them. I didn't go any further to see why the reads failed. I'm guessing it might have to do with the unused bits.

 

   -Bry

 

That is correct. Since the 5200 doesn't have as many keys as the computers there are scanning bits that go unused. The result is that a keypress actually causes 4 different keycodes to come back. Star Trek looks for two for one of the codes, then another, which probably how they handle de-bouncing the keypress.

 

Dan

Share this post


Link to post
Share on other sites

Both Star Trek and Pitfall work in Jum52 Atari 5200 emu (V0.7/0.8).

 

Dan's right - there's a 'loose bit' in KBCODE that wiggles around and affects the result if not masked.

 

Some other games may not start with the "Start" button, but by pressing a number button, or the fire button, or wiggling the joystick (Beamrider).

 

- jum

Share this post


Link to post
Share on other sites

Joust will work only if you switch Atari800Win to NTSC. You probably have PAL video system set, since it's the default setting.

Share this post


Link to post
Share on other sites
Hi,

   I was just wondering if there was any patches or anything that I can do about Atari 5200 games that don't start in an emulator. Star Trek and Pitfall imediately come to mind as 2 games that I can't get to start in my 5200 emulator. I was just wondering if there was anything I could do.

 

Thanks

 

Get a real Atari 5200 :D

Share this post


Link to post
Share on other sites
Hi,

   I was just wondering if there was any patches or anything that I can do about Atari 5200 games that don't start in an emulator. Star Trek and Pitfall imediately come to mind as 2 games that I can't get to start in my 5200 emulator. I was just wondering if there was anything I could do.

 

Thanks

 

Get a real Atari 5200 :D

 

Actually I've had one since it first came out :wink:

I just find it easier sometimes to fire up an emulator to get in a couple of quick games....

Share this post


Link to post
Share on other sites

Zoinks!

 

I've never gotten River Raid to work! :sad:

 

Any suggestions on a different EMU or does my ROM have a bug?

Share this post


Link to post
Share on other sites

AFAIK, the 32k River Raid rom is "bad", so try the 16k rom, which works fine on Jum52 0.8 and 1.0 (in fact it's one of my favourites :)

 

- jum

Share this post


Link to post
Share on other sites

Has anyone got Pitfall to work on an emulator as yet ? If so I would appreciate some advice.

 

I'm using Windows and have tried the following emulators:

 

Atari 800 Plus v4.0

Jum52 v1.0

MESS v1.103b

 

All have the same problem the game loads but doesn't respond when I press start.

Share this post


Link to post
Share on other sites

I took a crack at fixing the keyboard and initialization bugs in Pitfall.

 

This should work on 2 port or 4 port bios, with kbcode mask applied so it will work in the emulators as well.

 

Steve

pitfall__classics_fix_.zip

Edited by classics

Share this post


Link to post
Share on other sites
I took a crack at fixing the keyboard and initialization bugs in Pitfall.

 

This should work on 2 port or 4 port bios, with kbcode mask applied so it will work in the emulators as well.

 

Steve

999529[/snapback]

 

Hmm, I wonder how much different your patch is to the previous one someone did a year or two ago.

 

Mitch

Share this post


Link to post
Share on other sites
Hi,

    I was just wondering if there was any patches or anything that I can do about Atari 5200 games that don't start in an emulator. Star Trek and Pitfall imediately come to mind as 2 games that I can't get to start in my 5200 emulator. I was just wondering if there was anything I could do.

 

Thanks

576415[/snapback]

 

Why don't you just use the XL/XE versions. They should work perfectly fine in any emulator. Why bother, unless there's something special about the 5200 version.

Share this post


Link to post
Share on other sites
Beause Big Sexy deserves proper emulation. :P

1000143[/snapback]

 

 

Big Sexy is a Heavy Sixer is it not? A la 2600?

1000370[/snapback]

That's a misnomer. The 5200 is the REAL Big Sexy, as the heavy sixer is neither big nor sexy. :P

Share this post


Link to post
Share on other sites
Beause Big Sexy deserves proper emulation. :P

1000143[/snapback]

 

 

Big Sexy is a Heavy Sixer is it not? A la 2600?

1000370[/snapback]

That's a misnomer. The 5200 is the REAL Big Sexy, as the heavy sixer is neither big nor sexy. :P

1000499[/snapback]

 

Yes, but not nearly as sexy as that cute little avatar of yours. :D

Share this post


Link to post
Share on other sites
Beause Big Sexy deserves proper emulation. :P

1000143[/snapback]

 

 

Big Sexy is a Heavy Sixer is it not? A la 2600?

1000370[/snapback]

That's a misnomer. The 5200 is the REAL Big Sexy, as the heavy sixer is neither big nor sexy. :P

1000499[/snapback]

 

Yes, but not nearly as sexy as that cute little avatar of yours. :D

1000601[/snapback]

But Lucia's not big. She's Little Sexy. :)

Share this post


Link to post
Share on other sites
Has anyone got Pitfall to work on an emulator as yet ? If so I would appreciate some advice.

 

I'm using Windows and have tried the following emulators:

 

Atari 800 Plus v4.0

Jum52 v1.0

MESS v1.103b

 

All have the same problem the game loads but doesn't respond when I press start.

999508[/snapback]

 

Pitfall works in Jum52 v0.8, but as you said it doesn't work in v1.0. It also works in the current version of VSS (http://danb.atarihq.com/)

 

Dan

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...